Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

i use nginx 1.2.3(php-fpm) php 5.4.7 pecl memcached 2.1.0 memcached 1.4.15

if memcached service stop or get a not found key,nginx return 502 error and in error_log:

2013/11/19 17:37:04 [error] 3972#0: *554345 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: x.x.x.x , server: www.site.com, request: "GET /test/mk.php?get=var1 HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "www.site.com"

php-fpm.log say: [19-Nov-2013 17:58:32] WARNING: [pool www] child 4626 exited with code 127 after 18.892556 seconds from start [19-Nov-2013 17:58:32] NOTICE: [pool www] child 4641 started

any body can help me?

sorry for my poor language.

share|improve this question

2 Answers 2

The ngnix error means that www.site.com/test/mk.php?get=var1 doesn't reply to the http request.

Try to call www.site.com/test/mk.php?get=var1 directly, without nginx to see what is been actually returned.

share|improve this answer
    
i run my php file from cli and get: php /srv/www/htdocs/hiclip/test/mk.php php: symbol lookup error: /usr/local/lib/php/extensions/no-debug-non-zts-20100525/memcached.so: undefined symbol: memcached_last_rrno my pecl memcached version is 2.1 and libmemcached version 0.30. i think update libmemcached solve problem.i test it later. –  ooghry Nov 20 '13 at 10:47

i update libmemcached to 1.0.17 and i can't compile pecl memcached 2.1 https://github.com/php-memcached-dev/php-memcached/issues/69 i install libmemcached 1.0.16 and install pecl memcached and my main problem solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.