Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to get our current install of Team Foundation Server (TFS) 2008 to properly send Alerts and Email Notifications.

The main issue that I'm running into is this error:


TF53010: The following error has occurred in a Team Foundation component or extension: Date (UTC): 8/18/2009 3:27:39 PM Machine: DEV02 Application Domain: /LM/W3SVC/681929560/Root/Services-2-128950828377749110 Assembly: Microsoft.TeamFoundation.Server, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a; v2.0.50727 Process Details: Process Name: w3wp Process Id: 4484 Thread Id: 6072 Account name: NT AUTHORITY\NETWORK SERVICE

Detailed Message: TF50282: Could not connect to the following e-mail server: 10.1.0.166 Error message: System.Net.Mail.SmtpException: Mailbox unavailable. The server response was: 5.7.1 Client does not have permissions to send as this sender at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response) at System.Net.Mail.MailCommand.Send(SmtpConnection conn, Byte[] command, String from) at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception) at System.Net.Mail.SmtpClient.Send(MailMessage message) at Microsoft.TeamFoundation.Server.WebServiceNotification.SendOneEmail(Boolean plaintext, String to)

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


Docs for TFS say to edit the web.config in DIVE\Program Files\Microsoft Visual Studio 2008 Team Foundation Server\Web Services\Services

My edits to the file are included below:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <appSettings>
        <add key="ConnectionString" value="Application Name=TeamFoundation;Persist Security Info=False;Initial Catalog=TfsIntegration;Data Source=DEV02;Integrated Security=SSPI"/> 
        <add key="eventingEnabled" value="true" />
        <add key="DetailedExceptions" value="false" />
        <add key="emailNotificationFromAddress" value="info@tradepmr.com" />
        <add key="smtpServer" value="10.1.0.166" />

<!-- Optional Alert Settings
     AlertUseReplyTo: True, False (default: True). Specifies that the ReplyTo property of the 
                 email alert should be set. When false, the From property is set.
        <add key="AlertUseReplyTo" value="True" />
-->
    </appSettings>
    <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
            <probing privatePath="bin\Plugins;bin\Plugins\zh-chs;bin\Plugins\zh-cht;bin\Plugins\de;bin\Plugins\es;bin\Plugins\fr;bin\Plugins\it;bin\Plugins\ja;bin\Plugins\ko"/>
        </assemblyBinding>
    </runtime>
    <system.web>
        <!-- Enable the HttpHandlers for file upload and download -->
        <httpHandlers>
            <add verb="*" path="methodology.asmx" type="Microsoft.TeamFoundation.Client.MethodologyDownloadHandler" />
            <add verb="*" path="methodologyUpload.asmx" type="Microsoft.TeamFoundation.Client.MethodologyUploadHandler" />
        </httpHandlers>
    </system.web>
</configuration>

Some things I am wondering are this:

  1. How should exchange be setup?
    • We're running Exchange 2007
    • I'm almost sure that anonymous sending is setup
    • Are their any repeater requirements
  2. How should TFS be setup? -Should the smtpServer attribute be an internal IP or the fully qualified local domain name? -What should the emailNotificationFromAddress be? - I've tested with one that we know works (web app sends to it), but I'd like the from name to be a distribution group so that team members can reply all when necessary. (I think that would require uncommenting the AlerUserReplyTo key, but I'm just trying to get emails to work period).

Any input would be awesome! Thanks!

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Looking at the configuration I can't see anything obviously wrong on the TFS side. However we had a similar problem and found that internal relay was switched off on Exchange for the particular server. Once it was allowed through it worked with no issues.

Tech Republic has a detailed article on allowing relay on Exchange 2007 here

For future reference however TFS 2010 has made the configuration of e-mail sending significantly easier with the new Administration Console. It is a 3 click process.

share|improve this answer
    
How do you go about switching on the internal relay in Exchange 2007? I did some quick Google searches but didn't find anything that I could try before I left work today. I plan on digging into this a little more in the AM, but I'm not understanding how this is going to solve the problem. I thought the whole thing would be solved by turning on Anonymous Access, but that didn't seem to help. –  Mike G Aug 19 '09 at 1:47
    
See updated answer. –  Diago Aug 19 '09 at 10:05
    
The Tech Republic site allowed me to fix how I had the Remote IP addresses setup for the Receive Connector. BTW for anyone else with this issue, it is important to follow the Tech Republic article so that you set it up such that it is only internal IPs that are allowed to do this. Thanks! –  Mike G Aug 19 '09 at 11:59

Exchange 2007 will require you by default to define a connector for that sending server (the TFS server) before it can connect to Exchange and send a message. Or, as stated in other post, turn on allowing relay from internal hosts is another possibility.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.