Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a problem with one of my FreeNAS 8 boxes. I was deleting some snapshots with zfs destroy when unfortunatelly my PC crashed and therefore killed the SSH-connection while a snapshot destroyment was in progess.

After reconnecting to the server, tried to redo the destroyment of the snapshot. It didn't give any error but ended very fast. After checking with zfs list -t snapshot I had to find out that the snapshot still exists. I've already tried using force mode, but that didn't change anything. Verbose-mode just tells me:

# zfs destroy -v -f u/@tokill
will destroy u/data@tokill
will reclaim 7.93M

When I try to delete it via the Webinterface, I get the strange message "Snapshot was cloned sucessfully", but the screenshot gets neither destroyed nor cloned. It is the last snapshot of that dataset and it is not cloned in any way. Unexpectedly I am able to rename that snapshot, but the deletion-problem still exists.

Anyone got an idea how I can get rid of that snapshot?

Thanks in advance,

David

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.