Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying generate XML SAML with signature to SSO, but I have a problem and I don't know what is wrong. I don't have experience with Linux. I generated privkey and cacert with lib openssl.

Next step, I install lib xmlsec1:

yum install xmlsec1

yum install xmlsec1-openssl

My test:

# xmlsec1 --sign --privkey-pem home/test/privkey.pem,home/test/cacert.pem --output /home/test/test.xml /home/test/tosign.xml

Error: func=xmlSecBufferReadFile:file=buffer.c:line=477:obj=unknown:subj=fopen:error=7:io function failed:filename=home/test/privkey.pem;errno=2 func=xmlSecGCryptAppKeyLoad:file=app.c:line=162:obj=unknown:subj=xmlSecBufferReadFile:error=1:xmlsec library function failed:filename=home/test/privkey.pem func=xmlSecAppCryptoSimpleKeysMngrKeyAndCertsLoad:file=crypto.c:line=118:obj=unknown:subj=xmlSecCryptoAppKeyLoad:error=1:xmlsec library function failed:uri=home/test/privkey.pem Error: failed to load private key from "home/test/privkey.pem". Error: keys manager creation failed

I tried with other example lib xmlsec and other privekey, but errors are the same.

share|improve this question
1  
Fixing the obvious typos in your command would be a good start. –  Michael Hampton Nov 22 '13 at 20:42
    
If you mean slash, I tried with and without slashes. /home/test/ home/test –  user3021242 Nov 22 '13 at 20:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.