Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install Icinga on a FreeBSD 9.1 box with Apache 2.4. I use the Apache config which was provided with the Icinga port.

But when i try to access the web frontend, i get the following error in my log:

AH01276: Cannot serve directory /usr/local/www/icinga/: No matching DirectoryIndex (none) found, and server-generated directory index forbidden by Options directive

I have a DirectoryIndex directive in my httpd.conf, but not in the Icinga config snippet, which uses index.html as an index. The Options directive is Options None.

When i try to specify a custom Directory Index in the Icinga config snippet, i get the following error:

Invalid command 'DirectoryIndex', perhaps misspelled or defined by a module not included in the server configuration

So Google tells me that maybe my mod_dir isn't enabled. Well, it is not in the modules list in httpd.conf where i can uncomment the modules to load, but i have a DirectoryIndex directive in my httpd.conf which is accepted by Apache.

So i am struggling to get the Icinga web frontend to work, and i was hoping that anyone can help me.

share|improve this question
can you access the webfrontend when opening it via url.tld/index.html ? – etagenklo Nov 23 '13 at 13:11
Yes, but my browser tries to download a file called tac.cgi. I think i have to look over my cgi config, but this would be my problem after i configured the DirectoryIndex. – simonszu Nov 23 '13 at 14:17
apachectl -M should tell you if mod_dir is loaded. If not, you should load it via httpd.conf. – etagenklo Nov 23 '13 at 22:26

The apache24 package on FreeBSD does not ship with the mod_dir. Check if it is present in /usr/local/libexec/apache24, and if not, install apache24 from ports. Add LoadModule dir_module libexec/apache24/ to your httpd.conf.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.