Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have puppet agent daemonized

# service puppet status
 * agent is running

And can confirm that it is retrieving the configurations from the master

# cat /var/lib/puppet/state/last_run_summary.yaml | grep last
    last_run: 1385262693
# date --date @1385262693
Sun Nov 24 03:11:33 UTC 2013

However changes I made to configurations hours since the last_run are not being applied. They are only applied if I run

# puppet agent --test

Why are the configurations not being applied when puppet is daemonized?

Here are the contents of /etc/puppet/puppet.conf on my puppet client

[main]
logdir=/var/log/puppet
vardir=/var/lib/puppet
ssldir=/var/lib/puppet/ssl
rundir=/var/run/puppet
factpath=$vardir/lib/facter
templatedir=$confdir/templates
prerun_command=/etc/puppet/etckeeper-commit-pre
postrun_command=/etc/puppet/etckeeper-commit-post
pluginsync=true

[master]
# These are needed when the puppetmaster is run by passenger
# and can safely be removed if webrick is used.
ssl_client_header = SSL_CLIENT_S_DN
ssl_client_verify_header = SSL_CLIENT_VERIFY

[agent]
server = puppetmaster.website.com
share|improve this question
    
paste ur puppet.conf on the client.... you may have the wrong value for puppet server –  nandoP Nov 24 '13 at 3:39
    
I've pasted the contents of /etc/puppet/puppet.conf. The address of the server the agent is contacting is a FQDN which requires DNS to resolve. –  user784637 Nov 24 '13 at 4:17
    
I am a bit confused why you have a [master] section on your clients. Are you seeing anything getting logged into your puppet logs on the client? –  Zoredache Nov 24 '13 at 6:02
    
run "puppet agent -t --server=puppetmaster.website.com" to make sure that entry is correct.... –  nandoP Nov 24 '13 at 6:23
1  
yes, agreed..... strange puppet client issues can be solved by "puppet cert clean fqdn" on master, and "rm -fv /path/to/cert/file" on client..... then run puppet agent, and its as if you are doing so for first time –  nandoP Nov 24 '13 at 9:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.