Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed phpMyAdmin on Ubuntu served with Nginx. I have installed phpMyAdmin using sudo apt-get install phpmyadmin. Configured it with the MySQL root password, and did not select an option when asked which web server I am using.

I also configured Nginx with the following server block

server {
  root        /usr/share/phpmyadmin;
  index       index.php;
  listen      80;
  error_log   /var/log/nginx/pma.error.log;
  access_log  /var/log/nginx/pma.access.log;
  server_name pma.mysite.me;

  location ~ \.php {
    include       fastcgi_params;
    fastcgi_pass  php5-fpm;
    fastcgi_index index.php;
  }
}

restarted Nginx and visit the site configured. All I get is the string Bad Request. There is no entry in Nginx error log (pma.error.log or error.log) or the php-fpm.log

I have also tried changing fastcgi_pass to use the UNIX socket instead and there isn't any difference

share|improve this question
    
Check that a file called fastcgi_params exists –  MultiformeIngegno Nov 24 '13 at 15:20
    
@MultiformeIngegno yes it does exist –  Angela Nov 25 '13 at 3:50

1 Answer 1

in location block, try:

fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;

share|improve this answer
    
Added, but no change either –  Angela Nov 25 '13 at 3:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.