Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an unusual issue with my Exchange 2010 environment. The set-up is as follows:

  • 5x domain controllers - (2x2003, 2x2012, 1x2008)
  • Domain Function Level is: Windows Server 2003
  • Server 2003, Exchange 2003 Ent SP2
  • Co-existence
  • Server 2008 R2, Exchange 2010 Std SP3

A dcdiag /v /a /q shows everything is healthy.

The issue we are having is:

  1. A user is created via Active Directory (no mailbox).
  2. NOTE: We wait up to 15 minutes and have confirmed replication is working in AD as the other DC's have the user present. We attempt to add a mailbox to the user via Exchange 2010 using the Exchange Management Console.
  3. The user is not visible within "Recipient Configuration". NOTE: We are not searching for the user under "Recipient Configuration > Mailbox"
  4. If we attempt to use the find feature it does not find the user
  5. We are able to mail enable the user if we use the Exchange Management Shell.

At first I thought that perhaps the EMC may have had a filter on it, but this does not appear to be the case. I have also tried to reset the MMC cache (C:\Users\%username%\AppData\Roaming\Microsoft\MMC) by renaming the file.

Has anyone come across this problem or does anyone have any ideas?

share|improve this question
    
Have you tried closing the EMC and reopening it, just to be sure its not showing old information? (it shouldn't anyways if you are searching, but worth a try) –  Grant Nov 25 '13 at 1:35
    
Yeah I have tried that, and like I said I even cleared the MMC cache. Thanks for the suggestion though. –  Dave Nov 25 '13 at 3:09
    
Also probably not going to work, but try logging in under a different admin account? –  Grant Nov 25 '13 at 3:32
    
Does the user shows if you restart "Exchange AD topology"? –  Vick Vega Nov 25 '13 at 6:03

2 Answers 2

I know this question is super old but I'm hoping my answer can clear this up for anyone who comes across this. I had this problem today, and what solved it for me was to make sure the attribute msExchRecipientTypeDetails in the user's AD profile is not set.

What caused this for me was that a user had a mailbox previously, but they no longer needed access to email, so their mailbox was disconnected and deleted. When a user is assigned a mailbox, that attribute is set to 0. When the user's mailbox was deleted, this attribute did not get reset for some reason. So, when I tried to create a new mailbox for them, they would not show up in the find dialogue, because that value was set to 0 instead of being not set.

Hope this helps somebody in the future!

EDIT: I just realized you said you created an AD account with no mailbox. Then you say that you were searching for them under recipient configuration. I do not believe users without mailboxes show up there, as they are not considered recipients until they are assigned a mailbox.

share|improve this answer

Did you check the search scope in the select user dialog?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.