Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have hardware connected to router with DHCP server. That router has MAC reservation to make sure hardware be assigned to specific IP. When this setup isolated everything is fine, but if I connect WAN port of router to local network, hardware gets dhcp of primary domain controller(which is somehow far from haardware! not first host on way like 1st router). Why dhcp packets bypass my router? Is it something standard? How to avoid? Thanks!

1. [HW]<->[Router1/DHCP1]    
- Isolated network. HW get correct IP from DHCP MAC reservation: 10.23.205.89

2. [HW]<->[Router1/DHCP1]<--->[LAN]<--->[PDC/DHCP2]<--->[GW]<-->[Internet]
- DHCP request bypass Router1 and gets IP from PDC/DHCP2 172.168.100.100 f.e.

Router1 Model: TP-LINK TL-WR1043ND

share|improve this question

closed as off-topic by TheCleaner, cole, mdpc, Grant, Falcon Momot Nov 27 '13 at 8:56

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – TheCleaner, cole, mdpc, Grant
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
1. Why would you connect the router WAN port to your LAN? 2. Either assign the hardware a static ip address manually or get rid of one of your DHCP servers. –  joeqwerty Nov 26 '13 at 14:24
    
1.For remote debug session. 2. That HW is some primitive powerpc board. Has only DHCP preconfigured. –  Boris Ivanov Nov 26 '13 at 14:37
    
I think that updating the question with model of your router will be helpful. –  Veniamin Nov 26 '13 at 15:20
    
I mean router modelname indeed. –  Veniamin Nov 26 '13 at 16:07
    
@BorisIvanov - Since you have no access to the Windows DHCP server, my best suggestion is to get with your netadmin to work through the details and get assistance. –  TheCleaner Nov 26 '13 at 19:19

3 Answers 3

There are multiple ways to handle this, some have already been mentioned, but I'll make it simple for you and build you a list of choices. You'll have to decide (and implement) the one you like...

  • assign the device a static IP (I know you said can't be done, but leaving it as a viable choice for others in the future)
  • if the router has the ability, disable DHCP relay/bootp relay for that particular port the device is on
  • change the VLAN and subnet the device is on and the port is on to its own and setup DHCP just for that VLAN on the router
  • disable DHCP on the router and instead set a reservation on the Windows DHCP server for that device
  • On the Windows server setup a MAC address DENY list for that device (http://technet.microsoft.com/en-us/magazine/ff521761.aspx). The hope would be that the device would continue to try for a DHCP address and hopefully the router will respond at that point.

Hope that helps.

share|improve this answer
    
Your idea with VLAN sounds interesting. Regarding PDC I have no access to it. –  Boris Ivanov Nov 26 '13 at 16:23

First thing that pops into my mind is, why do you even have 2 DHCP servers active on your network if they aren't clustered?

To answer your question though, when you have 2 DHCP servers on your network that aren't cooperating through eg. a cluster service on windows, it will usually be up to chance, and which is fastest to respond when it recieves the DHCP broadcast. Routers have been, when I've tested, slower to respond on DHCP and DNS requests than even a vm on a congested host.

My best suggestion is to disable the DHCP server you do not desire to have there.

share|improve this answer
    
PDC is common company-wide DHCP. Role of my router actually only in assigning IP for that hardware. Cos if its get random IP its not working properly. I would be happy to use it in isolated network(just router and hardware), but sometimes we need to provide remote session so we need to be connected to local network. I cannot disable company DHCP and cannot disable router DHCP. What I thinking is make some firewall setting to stop dhcp packets coming out first router. –  Boris Ivanov Nov 26 '13 at 14:07

The router should not perform in a such way, I suppose.

I can imagine two ways to get the result like this: dhcp-relay and bridging.

Passing dhcp request to an other subnet can be done with dhcp-relay functionality which usually works on managed switches -- in order to allow single DHCP server serving several subnets without complex multihome setup. I do not think this is our case.

More probable - WAL and LAN ports are turned out to be bridged due to the router is misconfigured or malfunctioning. First I was thinking: the router has special access-point mode, but I can not find any reference in tne manual.

I do not know about this router model exactly but some SOHO models are based on single switch which carries LAN and WAN ports placed to distinct VLANs. VLAN configuration is saved in nvram variables.

If nvram is corrupted then LAN anf WAN ports may be placed to the same broadcast domain and we will see the behavior like the observed. May be this was happened.

share|improve this answer
    
Thanks for your ideas. We use default TPLINK firmware I will try also OpenWRT one to see if it have same behavior. –  Boris Ivanov Nov 26 '13 at 21:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.