Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem with installing SOAP extension for PHP-FPM 5.5.6 (both 32 + 64 bit) with nginx on CentOS 6.4. I have enabled REMI repos and installed everything succesfully - except the SOAP extension.

When trying to install I am receiving following dependency error:

[root@local src]# yum --enablerepo=remi install php-soap
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.hexageek.com
 * epel: mirror.digmia.com
 * extras: mirror.hexageek.com
 * remi: mirror5.layerjet.com
 * updates: mirror.hexageek.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-soap.x86_64 0:5.4.22-1.el6.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.4.22-1.el6.remi for package: php-soap-5.4.22-1.el6.remi.x86_64
--> Finished Dependency Resolution
Error: Package: php-soap-5.4.22-1.el6.remi.x86_64 (remi)
           Requires: php-common(x86-64) = 5.4.22-1.el6.remi
           Installed: php-common-5.5.5-2.el6.remi.x86_64 (@remi-php55)
               php-common(x86-64) = 5.5.5-2.el6.remi
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php-common(x86-64) = 5.3.3-23.el6_4
           Available: php-common-5.4.21-2.el6.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.21-2.el6.remi
           Available: php-common-5.4.22-1.el6.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.22-1.el6.remi
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Installing from remi-test "yum --enablerepo=remi-test install php-soap" shows even older version php-soap 5.3.3.

Here's what I tried so far:

1/ pear install soap .... cannot install version 0.13.0 is not preferred stable, use channel 0.13.0 ... but I was not able to do it, how to switch channel..no clear documentation or not working...

2/

yum --enablerepo=remi install php-soap .... dependency issue for soap 5.4.22

yum --enablerepo=remi-test install php-soap .... dependency issue for soap 5.3.3

3/ I downloaded RPM from RPM downloaded packages and tried yum localinstall php-soap-5.5.6-1.fc20.remi.x86_64.rpm ... again dependency issue

Does anyone succeeded in installing PHP SOAP extension on PHP 5.5.6 with PHP-FPM?

I also checked at PHP but there is no info about anything, just "configure PHP with --enable-soap" which sounds like SOAP extension is already bundled into core .. ? I really need this extension badly and I dont want to downgrade PHP version.

Thanx a lot for any good advice:-)

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Read the output carefully again:

Installed: php-common-5.5.5-2.el6.remi.x86_64 (@remi-php55)

Using

yum --enablerepo=remi-php55 install php-soap

should help. Check this link.

And please do not try to install Fedora packages on CentOS.

share|improve this answer
    
Thank you very much, you saved my life:-) now it works and installed soap and also igbinary. Now I understand also how to interpret dependency messages:-) –  lubosdz Nov 30 '13 at 10:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.