Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having trouble installing samba on my CentOS 6.5 server. I run:

yum install samba

it finds the packages but then the following error messages appears and I cant continue:

Error: Package: samba-winbind-clients-3.6.9-151.el6_4.1.i686 (updates)
           Requires: samba-winbind = 3.6.9-151.el6_4.1
           Installed: samba-winbind-3.6.9-164.el6.x86_64 (@base/$releasever)
               samba-winbind = 3.6.9-164.el6
           Available: samba-winbind-3.6.9-151.el6.x86_64 (base)
               samba-winbind = 3.6.9-151.el6
           Available: samba-winbind-3.6.9-151.el6_4.1.x86_64 (updates)
               samba-winbind = 3.6.9-151.el6_4.1
           Available: samba4-winbind-4.0.0-55.el6.rc4.x86_64 (base)
               samba-winbind = 4.0.0-55.el6.rc4
Error: Package: glibc-2.12-1.107.el6_4.5.i686 (updates)
           Requires: glibc-common = 2.12-1.107.el6_4.5
           Installed: glibc-common-2.12-1.132.el6.x86_64 (@base/$releasever)
               glibc-common = 2.12-1.132.el6
           Available: glibc-common-2.12-1.107.el6.x86_64 (base)
               glibc-common = 2.12-1.107.el6
           Available: glibc-common-2.12-1.107.el6_4.2.x86_64 (updates)
               glibc-common = 2.12-1.107.el6_4.2
           Available: glibc-common-2.12-1.107.el6_4.4.x86_64 (updates)
               glibc-common = 2.12-1.107.el6_4.4
           Available: glibc-common-2.12-1.107.el6_4.5.x86_64 (updates)
               glibc-common = 2.12-1.107.el6_4.5
Error: p11-kit-trust conflicts with nss-3.14.3-4.el6_4.i686
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

It's been a very long time since i used Linux so I dont really know what to do about this, I have tried the commands suggested by the error message but it does not work. I'm experiencing the same problem when installing MySQL

share|improve this question
    
Try a yum clean all and yum update first. –  etagenklo Dec 1 '13 at 22:13
add comment

2 Answers

You've somehow gotten out of sync with the upstream distribution. To resolve this problem:

  1. Clear the yum caches.

    yum clean all
    
  2. Resync all your installed software with the latest available versions.

    yum distro-sync
    

    (Don't bother with yum update here; it isn't likely to help since it probably won't do anything anyway.)

Now try your installation again.

share|improve this answer
    
Your fix totally worked, now the question just remains how this could happen, it's a totally fresh install 6.5. But as long as it's working i'm happy :) Thank you! I dont have enough reputation to mark your post as answer :( –  user2782999 Dec 2 '13 at 6:07
    
You might have hit a mirror while it was in the middle of syncing, or something like that. And you should be able to accept the answer now. –  Michael Hampton Dec 2 '13 at 6:15
add comment

Try a yum update followed by yum install samba samba-client samba-winbind.

share|improve this answer
    
yum update returns that nothing needed to update, I did run it earlier today. Error: Package: samba-winbind-clients-3.6.9-151.el6_4.1.i686 (updates) similar error message appears after I try to run it, if I try to install only samba-winbind it says already installed? –  user2782999 Dec 1 '13 at 22:00
    
Try what Micheal Hampton suggested, clearing the yum cache and then resync. –  canadmos Dec 1 '13 at 22:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.