Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hi all first post here but already used stack overflow and was so impressed... :)

hope i'm not off topic here

i run development env on my ubuntu pc php is installed and runing but when calling phpmyadmin i get this error

Cannot load mcrypt extension. Please check your PHP configuration.

checking on installed packages it is installed any ideas why this is happening?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Go to your package manager and view all php packages. You will find an mcrypt package, not installed. Install this package with all dependencies, there are non-PHP libraries that this package depends on. restart apache with 'apachectl restart' after you have done this.

share|improve this answer

Solved it by restarting apache2

sudo /etc/init.d/apache2 restart

hopefully someone can use this in the future... :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.