Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem during the intallation of php 5.3.27. When I launch the. / Configure I get this error and does not complete the installation.

Configuring extensions
checking size of long... (cached) 8
checking size of int... (cached) 4
checking for int32_t... yes
checking for uint32_t... yes
checking for sys/types.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for string.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for strtoll... yes
checking for atoll... yes
checking for strftime... (cached) yes
checking which regex library to use... php
checking whether to enable LIBXML support... yes
checking libxml2 install dir... /usr/local/php530-cgi
checking for xml2-config path... /usr/bin/xml2-config
checking whether libxml build works... yes
checking for OpenSSL support... yes
checking for Kerberos support... yes
checking for krb5-config... no
checking for DSA_get_default_method in -lssl... no
checking for X509_free in -lcrypto... no
checking for pkg-config... /usr/bin/pkg-config
configure: error: Cannot find OpenSSL's <evp.h>

I state that I have already tried to update openssl, using the command yum-y install openssl-dev.


share|improve this question

closed as off-topic by Jenny D, Ward, mdpc, cole, MadHatter Dec 3 '13 at 10:00

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

Possible Duplicate of… – Hyppy Jan 12 '15 at 13:49

When I run yum whatprovides */evp.h, I get several packages that provide this file, all different versions of openssl-devel. Did you yum install openssl-dev or openssl-devel? If the former, that's the wrong package name.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.