Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For some weird reason I can not get jetty to properly deploy my gwt project. I have put the war folder in the webapps folder and renamed it to root after that i can start jetty and it recognizes the project and its web.xml.

2013-12-03 12:27:49.576:INFO:oejs.Server:main: jetty-9.0.6.v20130930
2013-12-03 12:27:49.699:INFO:oejdp.ScanningAppProvider:main: Deployment monitor [file:/home/spydon/bin/jetty/webapps/] at interval 1
2013-12-03 12:27:50.841:INFO:oejsh.ContextHandler:main: Started o.e.j.w.WebAppContext@321236f4{/,file:/home/spydon/bin/jetty/webapps/root/,AVAILABLE}{/root}
2013-12-03 12:27:50.943:INFO:oejs.ServerConnector:main: Started ServerConnector@5f909402{HTTP/1.1}{0.0.0.0:8080}

But when visiting the page(146.185.176.150:8080/) I can only see the static welcome page. No errors are recorded to the logs.

This is basically my web.xml, except that there is a lot more servlet mappings in the real one.

<web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"                                                                     [89/1588]
         xsi:schemaLocation="http://java.sun.com/xml/ns/javaee 
              http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"
         version="2.5"
         xmlns="http://java.sun.com/xml/ns/javaee">

  <!-- Servlets -->

  <servlet>
    <servlet-name>missionServlet</servlet-name>
    <servlet-class>net.mindlevel.server.MissionServiceImpl</servlet-class>
  </servlet>

  <servlet-mapping>
    <servlet-name>missionServlet</servlet-name>
    <url-pattern>/mindlevel/mission</url-pattern>
  </servlet-mapping>

  <!-- Default page to serve -->
  <welcome-file-list>
    <welcome-file>Mindlevel.html</welcome-file>
  </welcome-file-list>

</web-app>

It is jetty-9.0.6.v20130930 running on debian 7.0 x64

share|improve this question

1 Answer 1

up vote 0 down vote accepted

My fault, all of the GWT generated files did not make it to the server on deploy. So jetty was working perfectly fine all the time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.