Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Linux network set up with three sub networks 192.168.1.0 (chaos), 192.168.3.0 (chaos-hs), and 192.168.5.0 (ute-netz) with three machines casimir, ute, raspberry, a nas server nas and a router speedport:

192.168.1.1   casimir.chaos (serves as gateway for all local machines)
192.168.1.61  speedport.chaos (internet router)
192.168.3.1   casimir-hs.chaos-hs (dhcp server for chaos-hs and chaos)
192.168.3.3   ute.chaos-hs
192.168.3.80  nas.chaos-hs
192.168.5.1   ute.ute-netz (dhcp-server for ute-netz)
192.168.5.80  raspberry.ute-netz

The routing on casimir is set up as

Target          Router          Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.61    0.0.0.0         UG    0      0        0 eth1
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
192.168.3.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.5.0     192.168.3.3     255.255.255.0   UG    0      0        0 eth0

The routing on ute is set up as

Target          Router          Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.3.1     0.0.0.0         UG    0      0        0 eth0
192.168.3.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.5.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1

There is no firewall setup on casimir or ute.

All normal connections work, e.g. I can ssh and ping from ute, casimir and raspberry into any of the other machines. I can also ping the nas from casimir and from ute.

But I cannot ping the nas from raspberry.

My assumption is the problem is caused by the fact that the nas which gets its IP from casimir via DHCP installs a default route with gateway 192.168.1.1 but does not have an explicit routing for the ute-netz network. So, any requests from raspberry goto ute, then to the nas, but on their way back they go to casimir via chaos-hs and then would have to go back on the same interface chaos-hs to go to ute to eventually end up with raspberry.

I cannot log into the nas to control the routing. I can only supply configuration through DHCP.

Is there any way to further debug / fix this?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.