Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've posted this question on stackoverflow and was recommended to try this forum instead.

I have Ubuntu guest running on VmWare hosted by Windows 7. I tried to scp a file from a server PC to my machine, which didn't work, which is why I then tried to ssh. Both the ssh and scp requests time out.

I am able to ssh to that server, as that's how I get onto it in the first place. I can ping my machine from the server fine. I've also ssh'd to my Ubuntu machine from cygwin on my PC to make sure ssh port on it is open and accessible (albeit both are on the same physical PC). I've checked for iptables and ufw firewalls and neither are on on either the server or my Ubuntu.

The server is on a different subnet to my Ubuntu machine and desktop. The pinging works between all 3 (server, Ubuntu and cygwin). I've run traceroute on the server to my machine and I can see that the packet only gets as far as the gateway of the server.

I saw a similar question on serverfault and someone suggested running tcpdump -i eth0 port 22 and not host 01. I ran that on my Ubuntu and it looks like it's capturing packets from the server as 10.216.252.199 is the IP of the server:

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes
01:46:15.071002 IP 10.216.252.199.ssh > ubuntu.local.34834: Flags [P.], seq 4048624648:4048624760, ack 2754994889, win 198, options [nop,nop,TS val 1035272096 ecr 40874637], length 112
01:46:15.071499 IP ubuntu.local.34834 > 10.216.252.199.ssh: Flags [.], ack 112, win 176, options [nop,nop,TS val 40890410 ecr 1035272096], length 0
01:46:15.071695 IP 10.216.252.199.ssh > ubuntu.local.34834: Flags [P.], seq 112:192, ack 1, win 198, options [nop,nop,TS val 1035272096 ecr 40874637], length 80
01:46:15.071719 IP ubuntu.local.34834 > 10.216.252.199.ssh: Flags [.], ack 192, win 176, options [nop,nop,TS val 40890410 ecr 1035272096], length 0

Frankly I've no idea what else that means though. I'm just baffled as to how I can ssh from cygwin and ping from the server, but not ssh to Ubuntu from the server. Could this be something to do with the server's gateway/network?

Would really appreciate any help as I'm out of ideas.

share|improve this question
    
The tcpdump would be more useful while you attempt to ssh from the server to the Ubuntu machine. I have to ask, have you configured an ssh server on the Ubuntu desktop? Without that it won't work. –  Ladadadada Dec 4 '13 at 11:26
    
Yes there's an sshd service running. I can ssh to Ubuntu from cygwin on my PC so I know the port is open and ssh receives connections. That tcpdump was running while I connected from the server, so I think those messages should be from that connection attempt. –  Gatica Dec 4 '13 at 11:37
    
Looks like a Windows local firewall issue. Try to switch It off temporary. –  Veniamin Dec 4 '13 at 13:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.