Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In httpd-ssl.conf file I set :

CustomLog “C:/wamp/bin/apache/Apache2.2.11/logs/ssl_request.log” \
       "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

But Apache couldn't start since then and I have this error:

[error] (20024)The given path is misformatted or contained invalid characters: invalid transfer log path \x93C:/wamp/bin/apache/Apache2.2.11/logs/ssl_request.log\x94.

Any help is appreciated, Thanks.

share|improve this question

closed as off-topic by MDMarra, TheCleaner, cole, kce, mdpc Dec 5 '13 at 0:53

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – MDMarra, TheCleaner, cole, kce, mdpc
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Don't know if it's a copy/paste error, but look at the double quotes used to quote the path, they're not "straight quotes" (like those used the line below). –  Vinz Dec 4 '13 at 12:53

2 Answers 2

up vote 1 down vote accepted

Your problem seems to be related with the "double quotes" you used.

The error says : \x93C:/wamp/bin/apache/Apache2.2.11/logs/ssl_request.log\x94. We can see that the invalid characters are the first and the last ones. It corresponds with your "double quotes".

Use this kind of quotes : " instead of .

share|improve this answer
    
Thank you, that was the issue, i really uncommented it again and make the modifications you said, it is really working, appreciate it, thanks. –  Tiyeb Bellal Dec 4 '13 at 14:17

Try removing the double quotes and the extra space between the backslash and the double quote (\ "):

CustomLog C:/wamp/bin/apache/Apache2.2.11/logs/ssl_request.log \"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
share|improve this answer
    
Thank you guys, i just commented it all, and guess what, it worked!!. –  Tiyeb Bellal Dec 4 '13 at 14:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.