Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

'm administering Debian jessie VPS (2GHz, 1,4GB RAM). Since yesterday have terrible problem, can't even imagine what is it. So, my config is NGINX + PHP5-FPM and Wordpress on top.

Now, I've tried:

All nginx/php5-fpm conf files to default.
Turning off php - load disappears.
Turning off wordpress and running test.php with phpinfo() - no changes, 100% php5-fpm at start.
Enabling disabling php plugins (notably Zend Opcode)

I'm out of solutions here, people.

Any clues what can it be? It has something to do with php5-fpm config (or nginx's, maybe), yet defaulting it - eg. commenting out every change - does not introduce anything new. Still 100% load at start.

Help!

UPDATE: It seems when I turn off mysql daemon, and run php5-fpm - spike disappears. Although note sure why, since flush my.cnf haven't made any difference.

UPDATE: Did mysqlcheck -A -a , -o, -r. Did myisamchk. Tried playing with this settings: skip-external-locking

long_query_time = 4

innodb_buffer_pool_size = 16M key_buffer =32M max_allowed_packet = 16M thread_stack = 192K

myisam-recover = BACKUP tmp_table_size = 64M max_heap_table_size = 64M max_connections = 100

query_cache_limit = 8M query_cache_size = 16M

table_cache=1024

Still can't find the reason. php5-fpm alone works, mysqld alone works. when both are one, php5-fpm 100% cpu load in first second.

UPDATE: Seems script with echo Hello World! works. Also other WP sites work. Also this WP site works if not connected to DB. So, basically upon connecting of this particular WP to DB, 100% spike. Strange thing is that I've disabled most of plugins I doubt. Will see if theme has anything to do with it.

UPDATE: It is rather hard to establish the problem, when you can only run php5-fpm + mysql for 5 seconds, because if not killed, it will eventually eat up all RAM and deny you even plain reboot. I think it might be database issue. I'm inclined to do clean install and then table by table migrate old database back.

UPDATE: Finally traced issue to be theme related. Curiously, even in basic config theme causes overprocessing and hangs php5-fpm.

UPDATE: Fixed. Bottleneck, except from not the best optimized theme, was code styling translation & qtranslate plugin. Now I'd recommend to turn CST whenever unrequired, and as for qTranslate - http://wordpress.org/support/topic/evidence-on-how-slow-and-inefficient-qtranslate-is-please-do-something.

share|improve this question
    
Is this for a production site. Why did you pick jessie over the latest stable release? –  Drew Khoury Dec 7 '13 at 4:19
    
Hey, Drew! Yes, it is production site. I didn't pick jessie per say, I've picked Debian (that time stable was squeeze), and later on my hosting provider just upgraded the core to jessie. Its not really my choice, but also I'm not against it - latest version usually best in many aspects. –  user3072816 Dec 13 '13 at 22:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.