Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On my server I have 6 MySQL databases. They all power Wordpress websites. For some reason, 2 of these databases are not accessible. To my knowledge they use INNODB, but I can't confirm it as even doing a:


hangs on me. The working databases seem fine (at least the websites are online). When I tried to access the bad database websites, it will just keep spinning.

If I do a:

mysql> use rbb;
mysql> SELECT * FROM wp_posts;

It will just hang.

My server is running CentOS 6.2 and up to now i've had no issues.

Any pointers would be much appreciated. I have no idea what to do next.

Even opening a Sequel Pro to the server hangs the application.

If I try a query and then check the process list in another connection, it shows:

| Id | User | Host      | db  | Command | Time | State          | Info                   |
| 10 | root | localhost | rbb | Query   | 45   | Opening tables | SELECT * FROM wp_users |
share|improve this question
Check your MySQL logfile for any error messages. – etagenklo Dec 7 '13 at 22:04
Tried rebooting/restarting MySQL? Indeed also check MySQL error logs, usually somewhere in /var/log or /var/lib/mysql file is usually called [hostname].err. If you use Linux you can try to find it run: find / -name *.err – edwardmp Dec 7 '13 at 23:46

According to the mysql documentation, the 'opening tables' state shouldn't be seen unless there are locks getting in the way, or when your table_open_cache is too small.

Check mysql's errorlog to find out what happened, check the show engine innodb status output for innodb info.

share|improve this answer
And a relevant older thread ...… – Nikolaidis Fotis Dec 9 '13 at 9:36

Maybe a mutex / lock went wild ?

Probably a restart will fix. Otherwise you can check if there are any locks and release them by hand.


share|improve this answer
Tried a restart and it didn't work. Also, the FULL PROCESSLIST only shows 1 query and that is the PROCESSLIST query. – Thomas Lomas Dec 8 '13 at 12:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.