Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed Apache 2.2 through pacman in ArchLinux. My httpd.conf (haven't made any changes)

I wanted to start GeoClue server, but it's script tries to load some modules which are not present in my installation directory /etc/httpd/modules/

Nor are those modules loaded in my httpd.conf (please refer the paste linked above), which leads me to this doubt -

Is the script for some other version of Apache ? If yes, which version is it for ?

LoadModule unixd_module modules/mod_unixd.so
LoadModule access_compat_module modules/mod_access_compat.so
LoadModule authn_core_module modules/mod_authn_core.so
LoadModule authn_socache_module modules/mod_authn_socache.so
LoadModule authz_core_module modules/mod_authz_core.so
LoadModule authz_dbd_module modules/mod_authz_dbd.so
LoadModule mpm_prefork_module modules/mod_mpm_prefork.so

Thanks

share|improve this question
    
Thanks to Sling in #httpd, I got the answer that this is for Apache 2.4 .If you're facing similar version mismatch problem, install 2.4 from AUR (aur.archlinux.org/packages/apache24/?setlang=en) (version in official repos is 2.2) –  Parin Porecha Dec 9 '13 at 15:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.