Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Recently I've had quite a large influx of the error below in the error_log.

I've found out that it happens when someone browses my site using SSL https: and Internet Explorer, all other browsers are fine.

[Fri Nov 29 20:44:41.318847 2013] [core:notice] [pid 2307] AH00051: child pid 7504 exit signal Segmentation fault (11), possible coredump in /tmp/core-dump
[Fri Nov 29 20:44:41.318937 2013] [core:notice] [pid 2307] AH00051: child pid 7623 exit signal Segmentation fault (11), possible coredump in /tmp/core-dump
[Fri Nov 29 20:44:43.324859 2013] [core:notice] [pid 2307] AH00051: child pid 7724 exit signal Segmentation fault (11), possible coredump in /tmp/core-dump

I enabled core dumps and have run GDB on the core dump file:

GDB Analysis of Core Dump File

Core was generated by `/usr/local/apache/bin/httpd -k start -DSSL'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007fcc9b259798 in apr_uri_parse () from /usr/local/apache/lib/libaprutil-1.so.0

Backtrace

#0  0x00007fcc9b259798 in apr_uri_parse () from /usr/local/apache/lib/libaprutil-1.so.0
#1  0x00000000004f1e09 in stapling_renew_response ()
#2  0x00000000004f2f58 in stapling_cb ()
#3  0x0000003f4022b431 in ssl_check_clienthello_tlsext () from /usr/lib64/libssl.so.10
#4  0x0000003f4021b9e5 in ssl3_get_client_hello () from /usr/lib64/libssl.so.10
#5  0x0000003f4021db6f in ssl3_accept () from /usr/lib64/libssl.so.10
#6  0x0000003f402290d9 in ssl23_get_client_hello () from /usr/lib64/libssl.so.10
#7  0x0000003f402298b3 in ssl23_accept () from /usr/lib64/libssl.so.10
#8  0x00000000004dc63c in ssl_io_filter_handshake ()
#9  0x00000000004dd641 in ssl_io_filter_input ()
#10 0x000000000043e61c in ap_get_brigade ()
#11 0x0000000000440d8e in ap_rgetline_core ()
#12 0x000000000044161f in read_request_line ()
#13 0x0000000000442e30 in ap_read_request ()
#14 0x0000000000497045 in ap_process_http_sync_connection ()
#15 0x00000000004970a3 in ap_process_http_connection ()
#16 0x000000000046ba8f in ap_run_process_connection ()
#17 0x000000000046bf66 in ap_process_connection ()
#18 0x000000000051c378 in child_main ()
#19 0x000000000051c58e in make_child ()
#20 0x000000000051c943 in perform_idle_server_maintenance ()
#21 0x000000000051d0b5 in prefork_run ()
#22 0x000000000043bf35 in ap_run_mpm ()
#23 0x000000000043423c in main ()

The error is somehow linked to SSL settings, I am running Apache 2.4.7.mod_ssl, is there anything in the config files that I should change?


Apache Restart SSL Error

I've noticed if I restart Apache then I get the following in the error_log, are they related?

[Sun Dec 01 17:37:58.545564 2013] [ssl:error] [pid 8484] AH02218: ssl_stapling_init_cert: no responder URL

Update

If I downgrade my Apache to 2.2 then this error stops.

share|improve this question
1  
Kudos for a well written question - although I think you've got enough here to log a bug report with the Apache team - see httpd.apache.org/bug_report.html (this is similar, but I don't think it's the same as 55299) –  symcbean Dec 10 '13 at 15:07
    
Did you find a solution to this problem? I too get a Segmentation fault (11) when stopping apache 2.4 –  cherouvim Feb 11 at 10:34
    
Downgraded Apache to 2.2.26, not the best solution, hopefully it's gone in the next version. –  Silver89 Feb 11 at 10:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.