Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Ubuntu 12.04 Server x64 & Splunk 6.0

I installed Splunk according to the documentation. Started Splunk as directed and I am able to see it running in the terminal. I believe I correctly added the default port number - 8000 - to iptables with the following command:

sudo iptables -A INPUT -p tcp --dport 8000 -j ACCEPT

However, I am still unable to access it. It just continuously attempts to connect (white screen in browser) when I type in my domain name or public IP address followed by the IP address. I checked the Splunk logs and it is showing a standard startup without issues. I restarted and tried a few other quick fixes but so far nothing. Any ideas? Thanks in advance.

EDIT:

Leave it to outside influences. The client is hosting on Amazon EC2 and by default, all ports are blocked at the network level. You have to open the port up through AWS console. This is solved.

share|improve this question
    
what is the result for "netstat -an | grep 8000" from your server ? –  krisFR Dec 10 '13 at 18:11
    
tcp 0 0 0.0.0.0:8000 0.0.0.0:* LISTEN –  deeperDATA Dec 10 '13 at 18:50
    
Did you try to check if you have incoming packets on port 8000 on server side using tcpdump ? –  krisFR Dec 10 '13 at 18:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.