Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is making me go crazy. I am trying to block a user nathan to his home directory and not allowing him to crowse around. I read all the articles but chroot is not working for me. I have this in my vsftpd.conf file

# Example config file /etc/vsftpd/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=YES
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# The target log file can be vsftpd_log_file or xferlog_file.
# This depends on setting xferlog_std_format parameter
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# The name of log file when xferlog_enable=YES and xferlog_std_format=YES
# WARNING - changing this filename affects /etc/logrotate.d/vsftpd.log
#xferlog_file=/var/log/xferlog
#
# Switches between logging into vsftpd_log_file and xferlog_file files.
# NO writes to vsftpd_log_file, YES to xferlog_file
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd/banned_emails
#
chroot_local_user=YES
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (default follows)
chroot_list_file=/etc/vsftpd/chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# When "listen" directive is enabled, vsftpd runs in standalone mode and
# listens on IPv4 sockets. This directive cannot be used in conjunction
# with the listen_ipv6 directive.
listen=YES
#
# This directive enables listening on IPv6 sockets. To listen on IPv4 and IPv6
# sockets, you must run two copies of vsftpd whith two configuration files.
# Make sure, that one of the listen options is commented !!
#listen_ipv6=YES

pam_service_name=vsftpd
userlist_enable=YES
tcp_wrappers=YES

I am running CentOS release 5.10 (Final)

Users home directory is /var/www/html

seLinux 
-bash-3.2# sestatus
SELinux status:                 disabled
-bash-3.2#
share|improve this question
    
Is your user listed in /etc/vsftpd/chroot_list file? –  Laurentiu Roescu Dec 11 '13 at 7:00
    
there is nothing in my /etc/vsftpd/chroot_list . Its an empty file. –  user50946 Dec 11 '13 at 18:36

1 Answer 1

Did u notice this?

onnect_from_port_20=YES

A "c" is missing. For the rest, chrooting is the way to go, always worked for me. Check the content of /etc/vsftpd/chroot_list. Remember to restart the service after each change to the configuration. If the user's home dir isn't /home/user, check that he got access rights to it.

share|improve this answer
    
there is nothing in /etc/vsftpd/chroot_list. Its an empty file and I did restat vsftpd. User home directory is not /home/user. its /var/www/html –  user50946 Dec 11 '13 at 18:37
    
the configuration then seems ok, I use a similar one on one of my servers to let a user upload stuff to a website. Was the missing "c" in that file just a cut&paste mistake? –  stoned Dec 11 '13 at 20:15
    
Another thing which came to my mind when I saw that directory structure is.. are you using a RedHat derivate like Centos, and if so, is SELinux enable and enforced? Because if it is so, you must give ftpd the possibility to access to home dirs with the appropriate boolean. Execute: setsebool -P ftp_home_dir 1 If it won't let you write in the dirs because of the context, you might also need to use: setsebool -P allow_ftpd_full_access 1 –  stoned Dec 11 '13 at 20:30
    
I am using centos but seLinus is disabled –  user50946 Dec 13 '13 at 2:18
    
can you please confirm that with sestatus? Also, are you absolutely sure that your user got access to that directory, and to the ones on the top of it? Try to add your user to the apache group. What do your logs say? –  stoned Dec 13 '13 at 5:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.