Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Working on converting a Windows Server 2008 R2 machine from physical to virtual. Each time I run the converter it fails at 98%. I'm pretty sure the issue is occurring because vmware doesn't know what to do with the 'System Reserved' volume on the server.

The first time around I did not include the volume at all. I did some research and found that this volume is actually used during the boot, so no surprise it failed.

I tried the instructions provided by vmware regarding running Diskpart from the command line and setting the volume online. I got a success message but still no dice.

My screen shot below shows what vmware converter is showing. Is it supposed to show '\?\Volume...' for that 'System Reserved' volume or do I need to reconfigure something? These are Simple, Basic, NTFS Volumes.

Screenshot: http://i.imgur.com/68cLkJm.jpg

As always, thank you for any assistance.

Ben

share|improve this question
    
I've never experienced this problem due to the System Reserved volume. The VMware Converter doesn't know and doesn't care what it is. It simply sees it as an additional volume to convert. Maybe the problem is that the volume is 00 MB in size when it should be 100 MB in size. If you look at it in Disk Management on the source machine what size is it shown as? –  joeqwerty Dec 11 '13 at 14:59
    
It shows as 100. I think my screen shot is just cutting off the 1 before the two 00's. –  Ben B Dec 11 '13 at 15:01
    
The 95%-99% progress is used for re-configuring the VM (updating drivers, HAL, kernel, etc). There can be lots of things that go wrong here, but I don't think it will be the System Reserved volume. What do the converter logs show? –  jlehtinen Dec 11 '13 at 16:31
add comment

1 Answer

up vote 0 down vote accepted

Thanks for the help all. I gave it another go, this time I changed a few settings:

I checked the system reserved volume despite the \?\ stuff. I un-check the option to install vmware tools as part of the conversion.

In addition, I ran a disk re-frag and ended all non-OS related processes prior to starting the converter.

That seemed to do the trick, the server has been virtual for 2 days in production without issues.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.