Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a XP box running some MSMQ public queues. Windows 7 clients cant connect to these, however Windows XP clients can. When connecting from my Windows 7 client with a MSMQ Queue Explorer program, I get the following error message:

enter image description here

When setting up a new XP box, registering it in the domain, installing queue explorer, everything works fantastic. I should also note that my Windows 7 box has no problems connecting to OTHER XP boxes running MSMQ, just some of them (all running latest service packs).

After a LOT of debugging I've seem to isolated the problem down to the RPC calls being made. I see the following problem both when using Queue Explorer and rpcping. The example provided under is by using rpcping with the following command:

rpcping -s xp-host-1 -a integrity -u 9 && rpcping -s xp-host-2 -a integrity -u 9

xp-host 1 has the problem, xp-host-2 is a fresh install without the problem. Inspecting the data from wireshark provides this view. It is clear that the last RPC calls being made succeeds as you will see two additional calls being made to the second host.

enter image description here

Inspecting the packets reveal no distinct differences, however when using Queue Explorer against the two different servers (both XP) we see a difference. It seems to have something to do with authentication / challenge/response or something, but I am struggeling to find out what.

enter image description here

Does anyone have any idea how I can try solve this problem? I have tried to disable the different types of authentication types on my client to no avail. I've tried only lanman, ntlm v1, ntlm v2 and so forth.

Some other facts:

  • There is no information in the event logs regarding this
  • The MSMQ error codes are not giving a lot of information. Basically they mean "Something went bad, we dont know what".
  • If I use the IP address instead of Hostname, MSMQ does not give an error but does not allow me to view public queues.

EDIT 1 more picture:

It looks like it is the rpc__mgmt_inq_princ_name request that creates the problem. On the left side of the picture I try to connect to the host not working, on the right side I connect to same OS which is working.

enter image description here

share|improve this question

1 Answer 1

The problem was resolved when setting the MSMQ service to operate as Local Service Account. The previous user was a domain admin account.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.