Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Installation:

  • Windows Server 2008 R2
  • Remote Desktop Service role

When I logon locally my command window (cmd.exe) displays with default font that is 8x12. But when I logon remotely and open command window, it opens with the smallest possible font selection. Opening window properties and setting font size, the default 8x12 font is missing from the list.

What should I do to get this font back in the list?

Following screenshots show settings when logged on locally and remotely. Local machine is not Aero capable, but remotely I can have Aero environment. I've also tried setting it to basic, but there was no change.

Local logon
alt text

Remote logon
alt text

share|improve this question
    
What version of Remote Desktop Connection is in use? Which display resolutions and DPI settings are in use? Have you tried this from another remote system already? See my answer for why this might be relevant (serverfault.com/questions/56093/…). –  Steffen Opel Sep 15 '09 at 16:43
add comment

9 Answers 9

up vote 2 down vote accepted

Problem solution found !!! Change "System Locale" = Language for non - Unicode programs to US English and reboot. And then 8 x 12 font available again !

share|improve this answer
    
This will break the diacritic marks in most languages. –  kinokijuf Mar 9 '13 at 14:32
add comment

Interesting issue - this answer is just an attempt to encircle it rather than an immediate solution:

Section How Windows NT Matches Fonts within Chapter 8 - Fonts of the MS Windows NT Workstation 4.0 Resource Guide qualifies the Terminal font in question as Raster, fixed, display-dependent size, other than for example the MS Sans Serif font, which is qualified as Raster, proportional, 8, 10, 12, 14, 18, 24 (not to speak of the TrueType fonts, which are all scalable of course).

Unfortunately I have been unable to surface any particular font matching algorithm, still a quote from the almost ancient Windows 95 Printing and Fonts: The Basics might add to the picture, see section Fonts Provided for Compatibility:

The user interface in Windows 95 relies on TrueType fonts. However, three fonts — System, Fixed, and OEM (or Terminal) — are installed to support display and output devices to support other applications that may require these fonts. Each of these fonts supports two display types — 8514/a (1024x768) resolution and VGA (640x480) resolution.

Consequently I suspect the particular font size missing due to non matching characteristics of your remote desktop clients display capabilities, though admittedly this would be quite surprising giving all the other width/height pixel tuples available. Still the fact that the font is missing in PowerShell console too (as per comments to r0cas answer) would back this being a system wide font matching effect rather than an issue of any particular program like cmd.exe.

What should I do to get this font back in the list?

In case Windows font matching would indeed be causing this as suspected above, you might simply be unable to solve this. Eventually changing your clients display resolution and/or DPI settings could make a difference here though; whether this would be an option at all depends on your particular environment and requirements of course.

share|improve this answer
    
I'd be very interested why this has been voted down: it does not provide an immediate solution but I specifically mention this upfront; it may not be on the right track at all, but then stating what's wrong should be easy, in case I'd happily delete the answer to remove the noise. –  Steffen Opel Sep 16 '09 at 0:21
    
you've gone deep into this problem. thank you. +1 from me to even it out. –  Robert Koritnik Sep 16 '09 at 10:19
add comment

Radek, Your solution don't resolve this problem. If your language is different from the U.S. you don't have diacritics in console aplications after change system locale.

We had the same problem with missing raster fonts 8x12 in Windows 2008 Terminal Server sessions. I resolve this after install converted raster fonts to unicode Trutype fonts from this site: http://www.yohng.com/software/terminalvector.html

Enjoy!

share|improve this answer
add comment

Adding property Terminal with value app852.fon to registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts helped me.

share|improve this answer
add comment

Try to set the properties of Screen Buffer 80x420 and Window Size 80x25. This is the default setting of fonts 8x12.

Let me know...

share|improve this answer
    
no change. 8x12 still missing. –  Robert Koritnik Sep 10 '09 at 14:04
    
Is it the same problem with powershell? –  r0ca Sep 11 '09 at 13:21
    
yes. the same in powershell window. –  Robert Koritnik Sep 14 '09 at 11:36
add comment

This is something of a wild guess, but I wonder if this is related to the remote desktop font smoothing feature. You could try changing the RDC font smoothing setting. Within RDC, select Options -> Experience, then change the Font smoothing setting and try connecting again.

share|improve this answer
    
no change... even though I hopped for... –  Robert Koritnik Sep 11 '09 at 7:52
add comment

Something I often see is when RDPing into a machine, the locale of the the machine used to initiate the session is used - and if the remote machine misses that locale, things can mess up quickly... though in this case it seems completely implausible that the 12x8 version of the font is missing some of the characters needed on the initiating machine's locale - but it was my first thought so I thought I'd share it ^^

Have you tried RDPing into it from another machine than the one you're experiencing the problem from? RDP accelerates a lot of stuff at the client.

share|improve this answer
add comment

I did sfc /scannow in elevated CMD prompt (as I read somewhere else). It found no errors, but after I rebooted Windows 7, the 8x12 size came back.

share|improve this answer
add comment

Maybe that font is missing on the machine you're logging in remotely from. I think, by default, the windows command line uses font files (*.fon) for each specific size listed in the command prompt properties pane, instead of using normal TrueType fonts (*.ttf). Look in your fonts directory, you should be able to see them. I'm on windows 7 right now, so i can't look at this moment.

share|improve this answer
    
My question already states that this is only a problem when logging on remotely. Local logon displays thing just fine. –  Robert Koritnik Sep 14 '09 at 11:33
    
i meant the font could be missing on the machine you are logging in from. I said this in the first line of my answer –  Roy Rico Sep 14 '09 at 17:22
    
Why would my Remote session use any resources (like fonts) from a machine I'm connecting to. Imagine connecting to a non-win machine. This just wouldn't work. No. My machine has 8×12 raster font. –  Robert Koritnik Sep 15 '09 at 13:29
    
I thought remote desktop was different than VNC, in that, instead of sending an image of your desktop across the wire, it sent drawing commands (example: open window 600x400 pixels, use this font, draw this text). That's why it is able to operate much more efficiently than VNC. This is why I mentioned this. Sorry if that's not the case. –  Roy Rico Sep 15 '09 at 19:03
    
ok. valid argument. –  Robert Koritnik Sep 16 '09 at 10:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.