Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using pgadmin to copy a csv file into the database.

this worked fine a million times until today. I get the following error

Could not open file "/path.csv" for reading: permission denied

I poked around google, and some of the suggestions were to disable SELinux which i don't plan on doing, since my code worked before.

share|improve this question
up vote 1 down vote accepted

what are the permissions on the path.csv file? Perhaps the file was created by a different user than usual and you don't have read permission on it. Sure sounds like a simple file permissions issue and not a DB issue.

share|improve this answer
You're right, for some reason, it's a different user that owns it. How stupid of me ! – dassouki Aug 19 '09 at 14:43
happens to all of us, far too often ;-) – Devin Ceartas Aug 19 '09 at 14:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.