Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been tasked with some infrastructure updates related to upgrading to Rails 3 on our development server, which is running:

  • Red Hat Enterprise Linux AS release 4 (Nahant Update 5)
  • RPM version 4.3.3
  • Bash 3.00.15(1)-release
  • gcc version 3.4.6 20060404 (Red Hat 3.4.6-9)

As you can imagine, this involves all kinds of headaches, but the big roadblock of the moment is that there are several gems that depend on a JavaScript runtime, such as:

  • therubyracer - Google V8 embedded within Ruby
  • therubyrhino - Mozilla Rhino embedded within JRuby
  • Node.js

But i have been unable to manage to get any of these installed - problems encountered are various and complicated :(.

I have initiated a request to upgrade the operating system, but need to try to move forward on this regardless of IT's timeline.

Any more specific info that would help, please let me know! Thanks for your time.

share|improve this question
5  
You're trying to develop modern Rails apps on RHEL 4?! That's utterly insane. –  Michael Hampton Dec 12 '13 at 23:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.