Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm on Ubuntu server (I think it's 12.04, but not positive) and I basically ran into this problem here Unmount a nfs mount where the nfs server has disappeared

The umount command didn't work, so I tried to just use the ol' reboot. Now the machine gets an error when booting:

FS-Cache:netfs 'nfs' registered for caching
<two minutes later>
init: udevtrigger post-stop process (345) terminated with status 1

I tried booting in recovery mode so I could just comment out the bad NFS mount in my /etc/fstab file, but I wasn't able to write the changes.

I basically just want to get the machine booting properly again so that I can erase the bad mount point, either order is fine.

What are my options here?

share|improve this question

2 Answers 2

You can try to do this in rescue mode:

mount -o remount,rw /

and then modify your /etc/fstab.

Or boot LiveCD and mount / somewhere with "rw".

share|improve this answer
    
So I got into recovery mode and ran mount -o remount,rw / which allowed me to get rid of my bad NFS mounts in /etc/fstab, but now my boot (in non-recovery) has seemingly gotten worse -- I get no output on the screen after selecting normal boot from the GRUB menu! –  s g Dec 13 '13 at 22:36
    
It has nothing to do with you removing NSF record with /etc/fstab. use alt + ctl to switch tty to see what comes on boot to stdout to see any boot errors. –  Danila Ladner Dec 13 '13 at 23:46
up vote -1 down vote accepted

I got into recovery mode and ran mount -o remount,rw / which allowed me to get rid of my bad NFS mounts in /etc/fstab (and I prevented further issues by adding the intr option to the NFS entries), but then my boot (in non-recovery) seemingly got worse -- I got no output on the screen after selecting normal boot from the GRUB menu!

I then added nomodeset to the GRUB_CMDLINE_LINUX_DEFAULT boot option list and everything worked.

I have no idea how those two were related, but that's what fixed the issue.

share|improve this answer
    
So you really did exactly what @DanilaLadner recommended. Why post your own answer with the same content instead of just accepting his answer? –  EEAA May 20 at 20:51
    
Because there was additional information –  s g May 20 at 20:53
    
He pointed you in the right direction. If there was additional info, edit his answer and include it and then accept that answer. –  EEAA May 20 at 20:54
    
Sir! Yes, Sir!! –  s g May 20 at 20:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.