Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Not sure if I should asking this here but am quite stuck at the moment.

I wouldn't be the best on Linux but can get around. My issue is with Yum update on my CentOS 6.3 x64 system.

Basically for some reason after installing Murmur (Mumble) it won't let me update - I have a feeling it is to do with one or more of the required packages.

This is what I get when running 'yum update':

yum update
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: ftp.heanet.ie
 * epel: ftp.heanet.ie
 * extras: ftp.heanet.ie
 * updates: centos.weepeetelecom.nl
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package bash-completion.noarch 1:1.3-5.el6 will be updated
---> Package bash-completion.noarch 1:1.3-7.el6 will be an update
---> Package db4-devel.x86_64 0:4.7.25-18.el6_4 will be obsoleted
--> Processing Dependency: db4-devel for package: 4:perl-devel-5.10.1-136.el6.x86_64
Package db4-devel is obsoleted by db53-devel, but obsoleting package does not provide for requirements
---> Package db53-devel.x86_64 0:5.3.21-1ice.el6 will be obsoleting
---> Package mod_python.x86_64 0:3.3.1-14.el6.1 will be updated
---> Package mod_python.x86_64 0:3.3.1-16.el6 will be an update
--> Finished Dependency Resolution
Error: Package: 4:perl-devel-5.10.1-136.el6.x86_64 (@base)
               Requires: db4-devel
           Removing: db4-devel-4.7.25-18.el6_4.x86_64 (@base)
               db4-devel = 4.7.25-18.el6_4
           Obsoleted By: db53-devel-5.3.21-1ice.el6.x86_64 (zeroc-ice)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Now I can see two familiar items, based on the install instructions for Murmur:

1 - perl-devel-5.10.1-136.el6.x86_64: I think this relates to epel-release-6-8.noarch.rpm

2 - db53-devel-5.3.21-1ice.el6.x86_64: Which possibly relates to this, zeroc-ice-el6.repo


Would I be on the right track here? If so how would I go about resolving this?

The install instructions are here:

http://mumble.sourceforge.net/Install_CentOS6

  • Under the heading: New packages 1.2.4 (x64)

Any help is appreciated, even if I am only pointed in the right direction.

Thanks all.

UPDATE >>

So I tried 'Michael Hampton' solution and all was fine until installing murmur; all I get is the following:

yum install murmur
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: ftp.heanet.ie
 * extras: ftp.heanet.ie
 * updates: ftp.heanet.ie
Setting up Install Process
No package murmur available.

So then I tried to just install it, and got this:

rpm -ivh https://www.dropbox.com/s/hs0ztzrdy4unn75/mumble-server-1.2.4-1.el6.i686.rpm
Retrieving https://www.dropbox.com/s/hs0ztzrdy4unn75/mumble-server-1.2.4-1.el6.i686.rpm
error: Failed dependencies:
    libIce.so.35 is needed by mumble-server-1.2.4-1.el6.i686
    libIceUtil.so.35 is needed by mumble-server-1.2.4-1.el6.i686
    libQtCore.so.4 is needed by mumble-server-1.2.4-1.el6.i686
    libQtDBus.so.4 is needed by mumble-server-1.2.4-1.el6.i686
    libQtNetwork.so.4 is needed by mumble-server-1.2.4-1.el6.i686
    libQtSql.so.4 is needed by mumble-server-1.2.4-1.el6.i686
    libQtXml.so.4 is needed by mumble-server-1.2.4-1.el6.i686
    libcap.so.2 is needed by mumble-server-1.2.4-1.el6.i686
    libcrypto.so.10 is needed by mumble-server-1.2.4-1.el6.i686
    libdns_sd.so.1 is needed by mumble-server-1.2.4-1.el6.i686
    libgcc_s.so.1 is needed by mumble-server-1.2.4-1.el6.i686
    libgcc_s.so.1(GCC_3.0) is needed by mumble-server-1.2.4-1.el6.i686
    libgcc_s.so.1(GLIBC_2.0) is needed by mumble-server-1.2.4-1.el6.i686
    libprotobuf.so.6 is needed by mumble-server-1.2.4-1.el6.i686
    libssl.so.10 is needed by mumble-server-1.2.4-1.el6.i686
    libstdc++.so.6 is needed by mumble-server-1.2.4-1.el6.i686
    libstdc++.so.6(CXXABI_1.3) is needed by mumble-server-1.2.4-1.el6.i686
    libstdc++.so.6(GLIBCXX_3.4) is needed by mumble-server-1.2.4-1.el6.i686
    libz.so.1 is needed by mumble-server-1.2.4-1.el6.i686
    qt-sqlite is needed by mumble-server-1.2.4-1.el6.i686

Lastly I tried:

yum --nogpgcheck localinstall mumble-server-1.2.4-1.el6.i686.rpm

On the package itself and the same complaint.

Is it that the murmur install, for YUM, is not linked up on CentOS? It appears that it is Fedora. Sorry I don't know the correct terminology here.

share|improve this question

3 Answers 3

You're on the right track. What's happened is that the zeroc-ice repository has a package (db53-devel) that obsoletes a package provided by the base repository (db4-devel), but the obsoleted package is required by other packages you have installed. Long term, the proper fix is for the zeroc-ice repo maintainers to correct the provides tag for db53-devel so that it also provides the db4-devel functionality. Short-term, my best recommendation is for you to disable the zeroc-ice repository during your update: yum update --disablerepo=zeroc-ice.

share|improve this answer
2  
Incidents like this is why I almost always disable installed non-standard repositores immediately after installation, which forces me to --enablerepo=name any time I think I actually need it. –  David Mackintosh Dec 13 '13 at 14:57

There is no murmur package in EPEL for Centos 6. So the solution to remove the zeroc ice repository is incorrect.

"yum install murmur" would only have worked if the package existed in EPEL. To manually install the RPM you have downloaded you need the zeroc-ice repository for dependencies.

As yum suggests, you can use --skip-broken to skip the broken dependency issue and update the other packages on your system, or you can disable the repository by setting enabled=0 in /etc/yum.repos.d/zeroc-ice-el6.repo.

share|improve this answer
    
Wow. It was there two weeks ago. What happened to it? –  Michael Hampton Dec 26 '13 at 16:49

The only thing that you must to do is, edit from repositories file on my Centos, for example is in the path:

/etc/yum.repos/Centos-Base

remove all lines of reposotories that depends of zeroc-ice

thats all..

regards!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.