Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to RDP to a client's server. When trying from Windows 2008 R2, I get the following error after being prompted for my credentials:

From Windows 2008 R2

When I try from Windows 2012, I get an error about the certificate and if I choose to ignore, it connects normally:

From Windows 2012

Why don't I get the option to ignore that error and connect anyways from Windows 2008 R2?

share|improve this question
1  
What are your RDP settings on the 2012 box? –  DanBig Dec 13 '13 at 19:07
    
On the 2K8R2 box check the server authentication options on the Advanced tab. –  joeqwerty Dec 13 '13 at 19:19
    
Are you using Network Level Authentication at W2K8 side ? –  krisFR Dec 13 '13 at 23:36
    
Server auth is set to "warn me", and I already tried the option to just connect. I am using NLA which is why I'm being prompted for login before the session is opened. –  blizz Dec 14 '13 at 5:53

1 Answer 1

I think W2012 shipped with a new version of RDP. Have you tried upgrading your Windows RDP client on your W2K8 box ?

share|improve this answer
    
Where could I find that update? The system is pretty current on automatic updates from what I can see. –  blizz Dec 13 '13 at 22:51
    
@Rico : i don't think an update can solve the problem, i connect everyday using RDP to non updated w2k8R2 servers (i know, bad...). I got certificate warning but have no issues to connect –  krisFR Dec 13 '13 at 23:39
    
This is for example an article describing the changes in the new Remote Desktop Protocol (8.1) support.microsoft.com/kb/2830477/en-us . otherwise you can try an alternative client like 2x: 2x.com/rdp-client/windows-linux-mac/downloadlinks –  Rico Dec 13 '13 at 23:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.