Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

In the newer server versions when right clicking on My Computer / This PC, we are presented with the option to 'Manage', when clicked it opens the Server Manager, which can take up to 10-20 seconds in slower machines. In prior versions, this would open up compmgmt.msc and take 1-2 seconds to open.

At work we make small changes daylong and all our techs have coffee, donut, or phone in their free hands and cannot make use of the Winkey + X start menu. Thus avoiding those types of responses - double wink.

Is there any way we can just modify the registry forcing the Manage link to behave like it did in older versions of Windows Server i.e. spawn compmgmt.msc instead of server manager.

share|improve this question

2 Answers 2

up vote 5 down vote accepted

This registry snippet should alleviate all that, run it from Powershell (as admin) and when you right click This PC 'Manage' it will open compmgmt.msc directly. Works instantly.

Enable - Manage via CompMgmt.msc

Set-ItemProperty -Path 'registry::HKEY_CLASSES_ROOT\clsid\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage\command' -Name "(default)" -Value "mmc %SystemRoot%\system32\compmgmt.msc"
#

Restore original setting - Manage via Server Manager.

Set-ItemProperty -Path 'registry::HKEY_CLASSES_ROOT\clsid\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage\command' -Name "(default)" -Value "%SystemRoot%\system32\CompMgmtLauncher.exe"
#

NOTE: One does not simply point to compmgmt.msc or it splashes a metro style half-screen error, cmd /c start /b method avoids it. Included a restore setting even though the OP didn't ask and probably won't use it.

share|improve this answer

This is probably on top of my list of annoyances on Server 2012.

Thanks for the answer, but that didn't quite work for me. I had to modify it a little and change it to different key:

Set-ItemProperty -Path 'registry::HKEY_CLASSES_ROOT\Launcher.Computer\shell\Manage\command' -Name "(default)" -Value "mmc %SystemRoot%\system32\compmgmt.msc"

This key was locked down so I had to give ownership to local admins and then add full control perms.

Thanks for your solution. My life is a little easier now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.