Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install Opencats.For that it is required to enable soap.I have enabled Soap.

soap
Soap Client => enabled
Soap Server => enabled
soap.wsdl_cache => 1 => 1
soap.wsdl_cache_dir => /tmp => /tmp
soap.wsdl_cache_enabled => 1 => 1
soap.wsdl_cache_limit => 5 => 5
soap.wsdl_cache_ttl => 86400 => 86400

But while installation Still it shows

PHP SOAP extension (soap) is not loaded.
Check your settings in php.ini.

CATS Open Source will function without SOAP, but CATS Professional functionality will not be supported.

Under certain Linux / BSD distributions, the PHP SOAP extension is a separate package.

Ubuntu: Run "apt-get install php-soap" and restart your webserver.

Debian: Run "apt-get install php5-soap" and restart your webserver.

FreeBSD: Install the php5-soap port, or configure SOAP support in the php-extensions port and restart your webserver.

I am using fedora 17 os. Php :PHP 5.4.17

php.ini

[soap]
; Enables or disables WSDL caching feature.
; http://php.net/soap.wsdl-cache-enabled
soap.wsdl_cache_enabled=1

; Sets the directory name where SOAP extension will put cache files.
; http://php.net/soap.wsdl-cache-dir
soap.wsdl_cache_dir="/tmp"

; (time to live) Sets the number of second while cached file will be used
; instead of original one.
; http://php.net/soap.wsdl-cache-ttl
soap.wsdl_cache_ttl=86400

; Sets the size of the cache limit. (Max. number of WSDL files to cache)
soap.wsdl_cache_limit = 5

Everything which is required i did. But still problem is not solved.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.