Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Installed Hyper-V Server 2012R2 on a server. Did NOT join the server to a windows domain.

Via sconfig.cmd I configured the network adapter, enable icmp, verified I could ping other PCs on the same lan segment and they could ping me, and enable remote desktop.

When attempting to remote desktop to the server I get this error: enter image description here

As others noted this issue is caused by the fact that sconfig.cmd will only enable the firewall rules for the Domain profile. Because this server is on a workgroup you have to enable it yourself with Enable-NetFirewallRule or as the poster noted an equivalent netsh command:

netsh advfirewall firewall set rule group="remote desktop" new enable=Yes

share|improve this question

closed as off-topic by TomTom, Jenny D, joeqwerty, MadHatter, Chris S Dec 16 '13 at 16:40

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must demonstrate a minimal understanding of the problem being solved. Try including attempted solutions, why they didn't work, and the expected results. See How can I ask better questions on Server Fault? for further guidance." – TomTom, Jenny D, joeqwerty, MadHatter, Chris S
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Voting to close. You should know how to configure windows to ask questions here - and this is ABSOLUTELY BASELINE. Set up network properly, configure firewall properly. Provide error message. –  TomTom Dec 16 '13 at 12:46
1  
In addition, you need to know how to ask a question. You've stated the problem but given us no detail about what happens and what messages you get when trying to connect. –  joeqwerty Dec 16 '13 at 15:31

2 Answers 2

if you haven't done so, open the Firewall for RDP, in PowerShell:

 Enable-NetFirewallRule -Name "RemoteDesktop-UserMode-In-TCP"
 Enable-NetFirewallRule -Name "RemoteDesktop-UserMode-In-UDP"
share|improve this answer

You need to make sure the firewall isn't blocking RDP. Find out what firewall profile the server is using, and ensure that RDP is allowed under that profile.

share|improve this answer
    
Assuming he used sconfig to configure the remote desktop on the host, this should have been handled automatically. –  Zoredache Dec 16 '13 at 20:40
1  
Eh, I did it on a new build of 2012 R2 at home just this weekend. It was allowed for the domain-profile rules, but not for the others, and it wasn't a domain machine, so I had to enable the non-domain rules. –  mfinni Dec 16 '13 at 21:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.