Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an mvc website hosted on IIS 7, Windows Server 2008, on Amazon server I think.

SSL certificate is set up and when browsing from the server everything works fine(except for the warning stating that the ssl is not registered for the domain(think that is because I was browsing using IP address instead of actual host name)). But publicly only http works. If I try accessing https, I get The connection has timed out. Same goes when domain name is set up and when using only IP.

I tried disabling windows firewall, and ran netstat which shows port 443 listening(I think, it was listed with local addresses as and [::], but no foreign address shows port 443). I also ran netsh which lists certificate on port 443. When using I get "A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond IpAddress:443"

Is there something I am missing? Any suggestion is really welcome. Also, could it be related to certificate itself? The certificate supplied didn't work at first and had to be converted to pfx using openssl.


share|improve this question
up vote 0 down vote accepted

If you are running this server inside Amazon's EC2 environment then you will need to edit the security groups settings to allow inbound traffic on port 443 for access from the internet.

share|improve this answer
That could be the issue, I had no idea that even existed. I don't have access to that panel so we will have to wait for a day for client to check it. – Hovan Gourmet Dec 17 '13 at 15:45
Turns out this was the issue. Client supplied credentials for the console, I updated inbound traffic for that instance security group to include port 443 and it works. – Hovan Gourmet Dec 20 '13 at 3:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.