Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am not able to login to my custom Linux system with the root user credentials as it says access denied. I have reset the root password by logging in via the admin user. The message in the syslog says maximum authenticated user exceeded for root. I checked the sshd_login file and that does not have any limit set for maximum remote users. Any insight on it will be appreciated.

This is when logging in to the box over the network via SSH. He only has network access to the device. PermitRootLogin is set to yes in sshd_config.

share|improve this question
    
This this a console login or an ssh login? –  EmmEff Dec 18 '13 at 15:17
1  
Is PermitRootLogin yes in your sshd_config? –  NickW Dec 18 '13 at 15:23
    
This is ssh login –  Kunal Sharma Dec 18 '13 at 15:32
    
yes PermitRootLogin is yes –  Kunal Sharma Dec 18 '13 at 15:33
    
Is the account locked? passwd -S root Do you have access restrictions on where root can login from ? check /etc/security/access.conf –  Jason Zhu Dec 18 '13 at 16:24

2 Answers 2

you have to make sure you have following enabled:

[alexus@XXX Desktop]$ sudo grep ^PermitRootLogin /etc/ssh/sshd_config
PermitRootLogin yes
[alexus@XXX Desktop]$ 

keep in mind that log in remotely as root is NOT recommended, you can always create a user and either use sudo or su to get to root's privileges...

share|improve this answer

Try to check if the option

PermitRootLogin no

is set in /etc/ssh/sshd_config

share|improve this answer
    
I checked that and it is set to yes –  Kunal Sharma Dec 18 '13 at 15:30
    
check also the file /etc/securetty here an explanation for what is used: /etc/securetty –  user1262272 Dec 18 '13 at 16:23
    
I tried with that as well..but still no go –  Kunal Sharma Dec 19 '13 at 3:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.