Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to enable SSL on a certain domain, but I can't see anything on it. The domain is api.conoform.com.

` # Fix MIME types AddType text/css .css AddType text/html .php AddType text/html .htm AddType text/html .html AddType text/javascript .js AddType text/cache-manifest *.manifest *.manifest.php

<FilesMatch "\.manifest|\.manifest\.php$">
    ExpiresActive on
    ExpiresDefault "access"
</FilesMatch>

# Compress some files
AddOutputFilterByType DEFLATE text/html text/plain text/xml application/x-httpd-php application/x-httpd-php5 text/css application/x-javascript text/javascript application/javascript application/ecmascript

# Enable rewrite engine
RewriteEngine on

ErrorLog /var/www/.log/error-ssl
LogLevel debug

LimitInternalRecursion 50

SSLEngine on
SSLCertificateFile /etc/apache2/ssl/apache.crt
SSLCertificateKeyFile /etc/apache2/ssl/apache.key

DirectoryIndex index.php index.html index.htm
DocumentRoot /var/www/api.conoform.com/

`

What am I doing wrong? I get an "This page is not available" message when I visit https://api.conoform.com/.

Regards, Kevin

share|improve this question

1 Answer 1

It look like SSH took over the port. This is my dump from Wireshark:

...........R..{U.X.S.j.....x..L]....H...5....$.+./..... ...9.5.........3.2...../. .............api.conoform.com...... .................#..3t.....". .spdy/2.spdy/3.spdy/3.1.http/1.1uO............ ....................SSH-2.0-OpenSSH_6.0p1 Debian-3ubuntu1

As you can see, it spits out an SSH header. Putty (my SSH client) works on port 443. You might want to look at your SSH configuration.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.