Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have configured squid for anonymous search and cache proxy. Initially it was working well, after two weeks it becomes slow(loading web page become slow) then again I had to looked into squid. I saw there was updated standard version of squid then I did update squid from 3.1.19 to 3.2.4. Now squid is running all the traffic from our network going through squid proxy server only. I see again internet connection is slow then I enabled cache feature in squid as

cache_dir ufs /var/cache/squid3 10240 32 512
cache_mem 256 MB

I checked the size of cache as

du -sh /var/cache/squid3


65 M

I checked the size of cache again after one day I see same 65 M, squid didn't cache anything at all. what would be the problem? should I configure anything else.

And the internet connection is very slow.

share|improve this question
What other settings do you have? There are many other squid options that directly modify the cachign behavior. There are options about the cache object size, the maximum age, and so on. – Zoredache Dec 19 '13 at 18:18
@Zoredache I have uncommented only above mentioned two lines for cache option, remaining are commented as it is default. – niren Dec 20 '13 at 8:34
I'd confirm that the users are using the proxy. tail -f access.log to see the activity. – diegows Dec 22 '13 at 12:53
@diegows I did tail -f /var/log/squid3/access.log, but I see no output – niren Dec 22 '13 at 13:33
There is the answer, your users aren't using the proxy. :) – diegows Dec 22 '13 at 17:21

The fact that there is nothing in the access.log suggests that the requests from clients aren't being routed through Squid at all but something else on the same server.

Could you post more information about your setup, Squid config and what you actually have on the same box (censoring it first of course).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.