Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server at 1and1 that I'm trying to setup with a set of static IPv6 addresses. I can't get it to work and have tried every forum and guide I could find on google. Their tech support has told me that the gateway is fe80::1. The IPv6 addresses I'm trying to use have been provisioned using the 1and1 control panel and are assigned to my account. IPv4 networking is setup and working fine, I just need help with IPv6.

Here's the relevant configuration files:

cat /etc/sysconfig/network

NETWORKING=yes
NOZEROCONF=true
GATEWAY=10.255.255.1
NETWORKING_IPV6=yes
IPV6FORWARDING=yes
IPV6_AUTOCONF=no
IPV6_AUTOTUNNEL=no
IPV6_DEFAULTGW=fe80::1
IPV6_DEFAULTDEV=eth0

cat /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0
BOOTPROTO=static
ONBOOT=yes
NAME=""
NM_CONTROLLED=no
MACADDR=""
MTU=1500
IPADDR=74.208.218.179
NETWORK=74.208.218.179
NETMASK=255.255.255.255
BROADCAST=74.208.218.179
IPV6INIT=yes
IPV6ADDR=2607:F1C0:812:7d10::/56
IPV6ADDR_SECONDARIES="2607:F1C0:812:7d10::1/56 2607:F1C0:812:7d10::2/56 2607:F1C0:812:7d11::/56"
IPV6FORWARDING=yes
IPV6_DEFAULTGW=fe80::1

I've setup forwarding for both IPv4 and IPv6 in the kernel via sysctl:

cat /etc/sysctl.conf

net.ipv4.ip_forward=1
net.ipv4.tcp_syncookies=1
net.ipv4.conf.default.rp_filter=1
net.ipv4.conf.default.accept_source_route=0
net.ipv6.conf.all.forwarding=1
net.ipv6.conf.all.accept_ra = 0
net.ipv6.conf.all.autoconf = 0
kernel.shmmax=68719476736
kernel.msgmax=65536
kernel.msgmnb=65536
kernel.sysrq=0
kernel.shmall=4294967296
kernel.core_uses_pid=1

Here's the output of some commands:

ifconfig

eth0    Link encap:Ethernet  HWaddr 00:19:99:27:2B:1D
        inet addr:74.208.218.179  Bcast:74.208.218.179  Mask:255.255.255.255
        inet6 addr: 2607:f1c0:812:7d11::/56 Scope:Global
        inet6 addr: 2607:f1c0:812:7d10::/56 Scope:Global
        inet6 addr: 2607:f1c0:812:7d10::1/56 Scope:Global
        inet6 addr: 2607:f1c0:812:7d10::2/56 Scope:Global
        inet6 addr: fe80::219:99ff:fe27:2b1d/64 Scope:Link
        UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
        RX packets:542041826 errors:158 dropped:0 overruns:0 frame:158
        TX packets:517716410 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:1000
        RX bytes:55707235613 (51.8 GiB)  TX bytes:441496177225 (411.1 GiB)
        Interrupt:19 Base address:0xc000

eth0:0  Link encap:Ethernet  HWaddr 00:19:99:27:2B:1D
        inet addr:74.208.109.145  Bcast:74.208.109.145  Mask:255.255.255.255
        UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
        Interrupt:19 Base address:0xc000

eth0:1  Link encap:Ethernet  HWaddr 00:19:99:27:2B:1D
        inet addr:74.208.125.133  Bcast:74.208.125.133  Mask:255.255.255.255
        UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
        Interrupt:19 Base address:0xc000

eth0:2  Link encap:Ethernet  HWaddr 00:19:99:27:2B:1D
        inet addr:74.208.113.67  Bcast:74.208.113.67  Mask:255.255.255.255
        UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
        Interrupt:19 Base address:0xc000

lo      Link encap:Local Loopback
        inet addr:127.0.0.1  Mask:255.0.0.0
        inet6 addr: ::1/128 Scope:Host
        UP LOOPBACK RUNNING  MTU:16436  Metric:1
        RX packets:2943936 errors:0 dropped:0 overruns:0 frame:0
        TX packets:2943936 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:0
        RX bytes:2949514917 (2.7 GiB)  TX bytes:2949514917 (2.7 GiB)

route -n -A inet6

Kernel IPv6 routing table
Destination                     Next Hop    Flags   Metric  Ref Use Iface
2607:f1c0:812:7d10::/56         ::          U       256     0   0   eth0
fe80::/64                       ::          U       256     0   0   eth0
::/0                            fe80::1     UG      1       45  0   eth0
::1/128                         ::          U       0       0   1   lo
2607:f1c0:812:7d10::/128        ::          U       0       12  1   lo
2607:f1c0:812:7d10::1/128       ::          U       0       0   1   lo
2607:f1c0:812:7d10::2/128       ::          U       0       0   1   lo
2607:f1c0:812:7d11::/128        ::          U       0       2   1   lo
fe80::/128                      ::          U       0       0   1   lo
fe80::219:99ff:fe27:2b1d/128    ::          U       0       9   1   lo
ff00::/8                        ::          U       256     0   0   eth0

Using this setup, I can ping the default gateway but not anything outside of the 1and1 network:

ping6 fe80::1 -I eth0

64 bytes from fe80::1: icmp_seq=1 ttl=64 time=0.442 ms
64 bytes from fe80::1: icmp_seq=2 ttl=64 time=0.447 ms
64 bytes from fe80::1: icmp_seq=3 ttl=64 time=0.450 ms
^C

ping6 ipv6.google.com

PING ipv6.google.com(ord08s12-in-x14.1e100.net) 56 data bytes
^C
--- ipv6.google.com ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 6052ms

Traceroute6 gives the following output:

traceroute6 ipv6.google.com

traceroute to ipv6.google.com (2607:f8b0:4009:806::1014), 30 hops max, 80 byte packets
 1  ae-1.gw-prtr-r5-2a.slr.lxa.oneandone.net (2607:f1c0:0:10::66:a)  0.819 ms  0.944 ms  1.073 ms
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

Is the problem that the gateway is fe80::1 and my ipv6 addresses are 2607:f1c0:812:...? I did have trouble getting the IPv4 setup working since my IPs (74.208..) were on a different subnet than the gateway (10.255.255.1).


Side Note: If it helps anyone else out there on a 1and1 server, for IPv4, you'll need to modify /etc/sysconfig/network-scripts/route-eth0 like so:

cat /etc/sysconfig/network-scripts/route-eth0

ADDRESS0=10.255.255.1
GATEWAY0=""
NETMASK0=255.255.255.255
ADDRESS1=0.0.0.0
GATEWAY1=10.255.255.1
NETMASK1=0.0.0.0
share|improve this question
    
I would expect to see the default gateway on your own network. Did the provider tell you that fe80::1 should be your default gateway? –  MadHatter Dec 19 '13 at 20:26
    
@MadHatter Yes. I had emailed 1and1 Tech Support and was told the default gateways were IPv4=10.255.255.1 and IPv6=fe80::1. Both gateways were not on the same network, but IPv4 is the only one I can get working. –  Alan Parks Dec 19 '13 at 20:56
    
Fair enough.... –  MadHatter Dec 19 '13 at 21:54
    
Please do not put the word "Solved" in the title. Mark your answer as accepted when the option is available to you. Thank you! –  Chris S Dec 20 '13 at 2:42

1 Answer 1

up vote 3 down vote accepted

The setup was correct. For anyone else out there with a 1and1 dedicated server, the only way I could get any traffic through is to completely deactivate the 1and1 IPv6 firewall via their control panel. Modifying the rules did not make a difference.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.