Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have this external SATA drive enclosure: http://www.newegg.com/Product/Product.aspx?Item=N82E16816111166

It came with a RAID card which is powered by a Silicone Image 3132 chipset. It's been working ok for about a year and a half, but today I had to hard reboot the server its connected to as it locked, and the array was degraded (drive in slot #2 was corrupted). I've had this happen a couple of times before but it was able to rebuild without issue.

Today though it got to about 4% and then the rebuild failed and the drive was orphaned. The software event log said "RAID Group/Path/Target 0:1:2, Sense Data 70:00:04:00:803000000000000 (ScsiError)"

I had it try to rebuild again but got the same result. I removed the drive from the port and replaced it with a different one I had, not the same make or model but enough to allow the array to rebuild. The same thing happened with this drive, so I began to suspect the drive was fine and it was the card. The WD diagnostics (quick scan) reported the drive was ok and so far I haven't seen any errors in the extensive scan.

Am I likely on the right path suspecting the card? Is there anything else I could do to track down the source of the issue so I can fix this?

Update: I used another enclosure via the esata raid card. The backups to that worked as it was a pass thru. I reconnected the old enclosure to the other esata port on the card, and this time it worked when rebuilding the array. Could this have been a heat issue with the card? anyone had a similar experience?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.