Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a virtual machine running ISPConfig 3 as a DNS, Email, Webserver etc.

I have one static public IP address, and have the registrar with the glue records/domain all configured properly.

All NAT has been configured with ports 21, 53, 80, 443, opened and ready.

The first domain (mynameserver.com) was created with A records for NS1 and NS2. (NS1.mynameserver.com, NS2.mynameserver.com). I have plans to add additional websites to this server using NS1.mynameserver.com, NS2.mynameserver.com.

When I add additional websites, I create the appropriate DNS records for them:

A   addondomain.com.    public.ip.address   0   3600

A mail public.ip.address 0 3600
A www public.ip.address 0 3600
MX addondomain.com. mail.addondomain.com. 10 3600
NS addondomain.com ns1.mynameserver.com 0 3600
NS addondomain.com ns2.mynameserver.com 0 86400

Using IntoDNS for my add-on domain I get the following errors: Mismatched NS records WARNING: One or more of your nameservers did not return any of your NS records. Error DNS servers responded ERROR: One or more of your nameservers did not respond: The ones that did not respond are: 111.222.333.444

My primary domain on the server (nameserver.com) functions without any issues.

Does anyone know what is going on and what I can do to properly have the zone records show during a request?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.