Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to make Samba 4 working, but it is really a horrible job. Now I got stuck on NSLCD. It works, however there are no account listed. I tried to run the nslcd daemon in the debug mode (/usr/sbin/nslcd -d). And when I run getent passwd, it writes following:

nslcd: DEBUG: accept() failed (ignored): Resource temporarily unavailable
nslcd: [8b4567] DEBUG: connection from pid=13343 uid=0 gid=0
nslcd: [8b4567] <passwd(all)> DEBUG: myldap_search(base="cn=Users,dc=barbucha,dc=local", filter="(objectClass=posixAccount)")
nslcd: [8b4567] <passwd(all)> DEBUG: ldap_initialize(ldap://bolbro.barbucha.local/)
nslcd: [8b4567] <passwd(all)> DEBUG: ldap_set_rebind_proc()
nslcd: [8b4567] <passwd(all)> DEBUG: ldap_set_option(LDAP_OPT_PROTOCOL_VERSION,3)
nslcd: [8b4567] <passwd(all)> DEBUG: ldap_set_option(LDAP_OPT_DEREF,0)
nslcd: [8b4567] <passwd(all)> DEBUG: ldap_set_option(LDAP_OPT_TIMELIMIT,0)
nslcd: [8b4567] <passwd(all)> DEBUG: ldap_set_option(LDAP_OPT_TIMEOUT,0)
nslcd: [8b4567] <passwd(all)> DEBUG: ldap_set_option(LDAP_OPT_NETWORK_TIMEOUT,0)
nslcd: [8b4567] <passwd(all)> DEBUG: ldap_set_option(LDAP_OPT_REFERRALS,LDAP_OPT_OFF)
nslcd: [8b4567] <passwd(all)> DEBUG: ldap_set_option(LDAP_OPT_RESTART,LDAP_OPT_ON)
nslcd: [8b4567] <passwd(all)> DEBUG: ldap_simple_bind_s("cn=Administrator,cn=Users,dc=barbucha,dc=local","***") (uri="ldap://bolbro.barbucha.local/")
nslcd: [8b4567] <passwd(all)> DEBUG: ldap_result(): end of results (0 total)

So it connects succefully to the LDAP, but then gets an empty list. But there are users in LDAP. It's really strange. Is there a way, how to debug LDAP results? Can I somehow execute ldapsearch in order to try to post the same query, the NSLCD sends?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.