Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am not in a very good situation at the moment, and bit stressed!

I have a Qnap nas (TS-410), this operates on a Marvell 6281 800MHz CPU, while I SSH'ed into the Nas box, I deleted the wrong folder (rm -rf), Is there anyway I can get this back?

The Nas is in raid 5 and file system ext4, I have tried to run photorec (using external drive), on the Nas but I get Command not found (also tried sudo).

Any help with getting the data back would be appreciated.

Thanks

share|improve this question
    
Just learn from the mistake. There are ways to potentially recover data like this, but you should be talking to a data recovery firm and not us. I don't think most people interface with their NAS via the SSH CLI. So that's another lesson... –  ewwhite Dec 26 '13 at 4:04

1 Answer 1

Since I'm assuming this is a production system in a professional environment, just restore from backup and stop fiddling around with trying to undelete the file.

share|improve this answer
1  
Rep on this. Local backups are key for anything. –  Frank Thornton Dec 26 '13 at 3:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.