Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have downloaded and installed Roundcube 0.9.5 on my xampp server on Windows 8.It works well when receiving mails as the mails show up in inbox normally.

But when i send a mail from the logged in account in roundcube(say gmail or yahoo) , I am able to see that mail in 'Sent' folder of the Sender but not able to see the mail land up in the Receiver's Inbox not even in Spam folder.

Can anyone tell me what problem it could be? I have configured Roundcube to take up the SMTP and IMAP settings from the user login so as to support multiple smtp servers using this plugin and my config folder's main.inc.php has these respective variables for that:

// IMAP
// ----------------------------------
$rcmail_config['default_host'] = array (
    'ssl://imap.gmail.com:993' => 'Google',
    'ssl://imap.mail.yahoo.com:993' => 'Yahoo',
    'ssl://imap-mail.outlook.com' => 'Outlook'
);

$rcmail_config['multiple_smtp_server'] = array (
    'Google' => 'ssl://smtp.gmail.com:587',
    'Yahoo' => 'ssl://smtp.mail.yahoo.com:465',
    'Outlook' => 'starttls://smtp-mail.outlook.com:587'
);

// TCP port used for IMAP connections
$rcmail_config['default_port'] = 993;

// IMAP AUTH type (DIGEST-MD5, CRAM-MD5, LOGIN, PLAIN or null to use
// best server supported one)
$rcmail_config['imap_auth_type'] = 'LOGIN';

// If you know your imap's folder delimiter, you can specify it here.
// Otherwise it will be determined automatically
$rcmail_config['imap_delimiter'] = null;

$rcmail_config['imap_ns_personal'] = null;
$rcmail_config['imap_ns_other']    = null;
$rcmail_config['imap_ns_shared']   = null;


$rcmail_config['imap_force_caps'] = false;

$rcmail_config['imap_force_lsub'] = false;


$rcmail_config['imap_force_ns'] = false;

// IMAP connection timeout, in seconds. Default: 0 (no limit)
$rcmail_config['imap_timeout'] = 0;

// Optional IMAP authentication identifier to be used as authorization proxy
$rcmail_config['imap_auth_cid'] = null;

// Optional IMAP authentication password to be used for imap_auth_cid
$rcmail_config['imap_auth_pw'] = null;

// Type of IMAP indexes cache. Supported values: 'db', 'apc' and 'memcache'.
$rcmail_config['imap_cache'] = null;

// Enables messages cache. Only 'db' cache is supported.
$rcmail_config['messages_cache'] = false;


// ----------------------------------
// SMTP
// ----------------------------------

$rcmail_config['smtp_server'] = '';


$rcmail_config['smtp_port'] = 25;


$rcmail_config['smtp_user'] = '';


$rcmail_config['smtp_pass'] = '';

$rcmail_config['smtp_auth_type'] = 'LOGIN';

// Optional SMTP authentication identifier to be used as authorization proxy
$rcmail_config['smtp_auth_cid'] = null;

// Optional SMTP authentication password to be used for smtp_auth_cid
$rcmail_config['smtp_auth_pw'] = null;


$rcmail_config['smtp_helo_host'] = '';


$rcmail_config['smtp_timeout'] = 0;

These are the entries in sendmail.log:

[26-Dec-2013 08:45:52 +0100]: User sender@gmail.com [::1]; Message for receiver@gmail.com; 
[26-Dec-2013 08:57:22 +0100]: User sender@gmail.com [::1]; Message for receiver@yahoo.com; 

There are no entries for today in error.log

Can anyone please help me out here and tell me what could be going wrong ?

Thanks a lot in advance..

share|improve this question

closed as off-topic by Dennis Kaarsemaker, kce, Ward, MadHatter, Falcon Momot Dec 31 '13 at 2:23

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – Dennis Kaarsemaker, kce, MadHatter, Falcon Momot
If this question can be reworded to fit the rules in the help center, please edit the question.

    
You should enable logging in the RC config. –  Kondybas Dec 26 '13 at 8:44
    
Yes logging is enabled, I have updated the question with the logged entries.. –  Aditya Dec 26 '13 at 9:07

1 Answer 1

xampp on windows 8. That smells like a home setup instead of a proper server, domain and mail config. This will fail horribly for email as many providers will block mail sent from home DSL connections due to spam issues. So don't do this. If you really want your own mailserver, get an el cheapo VPS with a proper mail setup on it.

share|improve this answer
    
Okay, so do you mean to say that Roundcube is working fine ? I actually want to build an application with Roundcube on my xamppp server and then upload it to a proper server! –  Aditya Dec 26 '13 at 16:56
    
Which is all very well, but if you bother to read the basic document on posting to SF, serverfault.com/help/on-topic, you'll see in big bold letters that questions about anything in a home or development environment are explicitly off-topic. –  MadHatter Dec 30 '13 at 16:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.