Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm very new to VMWare server, or at least, installing it and I'm having issues with the MUI. I have read many places that generally speaking, the root user is the only one that can access the MUI from the get-go. However, I cannot seem to get this to work. I've tried everything I can think of. I'm running Jaunty Ubuntu and the most recent VMware server version.

Any thoughts?

Thanks, Chris

share|improve this question
    
Can you GET to the MUI, and are just unable to authenticate, or is the problem with getting to the MUI in the first place? –  Adam Aug 20 '09 at 13:30
    
I can get to it, view the login screen and attempt to log in. I enter root/password and get a permission denied error –  Chris Thompson Aug 20 '09 at 18:24
add comment

2 Answers

Well you can run it outside the root account... I created a user vmware and used that as the user and specified that during the installation... Anyway, is the root account enabled and password set? By default Ubuntu disables the root account. You can the enable root account by issueing this command:

sudo passwd root

Enter your sudo password, if needed. Then enter password you want to use for root. However keeping root enabled and using the root account is not the best practice...

share|improve this answer
    
No beans. I'm still having issues authenticating. From what I recalled, it never asked me what account I wanted to use, is there a way to set that retroactively? –  Chris Thompson Aug 19 '09 at 21:28
    
It uses the built in OS accounts. By default, only the root user has access to login. –  Adam Aug 20 '09 at 13:28
    
@Adam That's what I thought. Any idea why it isn't working? –  Chris Thompson Aug 20 '09 at 18:23
add comment

I am running 1.0.9 on CentOS 5.3. In each case I have the VMware guests set with user ownership of root and group ownership of vmware and permissions set as 775. (user root and group vmware rwx and other as r-x). Ideally I would run not as root but think I need root access to be able to set the NIC into promiscuous mode. I haven't played with that yet.

I then have several OS users as members of the vmware group. When they log in using their OS account information, they can see and manage all guests.

If I want a guest to be private, I set its user and group ownership to be that private user.

share|improve this answer
    
You must be root to set promiscuous mode, correct. However, that is only needed on VMWare Server startup, not for the MUI or individual VMs. –  Adam Aug 20 '09 at 13:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.