Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This morning my Ubuntu server suddenly appeared in read-only mode.

Google says this can happen after updates.

I restarted the server and it booted with fsck errors:

Inodes that were parts of a corrupted orphan linked list found.
/dev/mapper/vg0-root: UNEXPECTED INCONSISTENCY: RUN fsck MANUALLY
fsck died with exit status 4

Google says you can only run fsck -n on read-only. I will runn that now nd hope to fix the inconstencies.

How can I undo the realy-only mounting of the root file system? Is it safe?

I'm not experienced much in administrating so I'd prefer host support, but it's the holidays...

share|improve this question

closed as off-topic by kce, Ward, MadHatter, Jenny D, Falcon Momot Jan 2 at 11:28

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must demonstrate a minimal understanding of the problem being solved. Try including attempted solutions, why they didn't work, and the expected results. See How can I ask better questions on Server Fault? for further guidance." – kce, Ward, MadHatter, Falcon Momot
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

up vote 1 down vote accepted

Usually, mounted file system are setup with errors=remount-ro option which is normal. This means that if your system encounter a disk problem/inconsistency it will set the FS read-only.

fsck -n will not repair/fix anything, it will just report problems.

Badly, to remount root file system read/write you will have to reboot your machine.

At boot the system will certainly perform a fsck with repair option. If it doesn't, reboot your machine in single user mode (recovery mode) and perform a fsck -r (repair) by yourself.

share|improve this answer
    
Thanks. fsck -r did the trick and it booted without read-only mode :) –  Martin Dec 26 '13 at 22:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.