Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a VirtualBox with Debian 3.2.51 guest (vcube) on Ubuntu 13.10 host (ring) with a bridged network adapter. vcube has an Avahi service configured with a vcube.local name.

I can see/ping/access vcube.local by Bonjour name, but cannot see it from other hosts on the (wireless) network. At the same time, there's a lot of wire- and wirelessly connected hosts on the network that we happily see in avahi-discover or other Zeroconf clients.

I have no access to our router and cannot know if it's blocking mDNS or not.

In iptables -vnL output, there are no entries, policies are ACCEPT and byte counts are 0 both on vcube and ring.

The same discovery problem happens for a copy of vcube VirtualBox on a totally different network.

Sometimes it just starts working - we suspect this happens when we start ANOTHER copy of vcube on a different host.

How do I diagnose or fix this problem?

share|improve this question
    
Are you able to ping the guest Debian OS by ip address from one of wireless devices? –  Tim Jan 1 at 2:22
1  
Something is blocking multicast UDP. You should run a packet dump (I suggest tshark, but tcpdump will do) in various places: 1. inside vcube on (-i) its virtual network adapter; 2. on ring, on the virtual adapter bridged to vcube; 3. on ring, on the physical network adapter (eth0 or such); 4. on another host on the network. You are looking for the mDNS packets, to see where they are blocked. To recap: sudo tcpdump -i eth0 'host 224.0.0.251 and port 5353' replacing eth0 as appropriate. –  Tobia Jan 2 at 18:31
    
@Tim, yes, it responds to IP address, but not to avahi name. –  Victor Sergienko Jan 4 at 9:28
    
Thanks @Tobia, will try it tomorrow. I believe this must be the answer. –  Victor Sergienko Jan 4 at 9:29

2 Answers 2

up vote 2 down vote accepted
+100

I am not sure I understood your problem very well but I know bridge interfaces and UDP multicasst/boradcast can trigger some eratics behaviours. To work it around you may want to disable multicast snooping on the bridge interface:

echo 0 > /sys/devices/virtual/net/$IFACE/bridge/multicast_snooping

Though I don't know virtualbox well enough to to be sure it uses proper linux bridge utils to setup bridge adpaters...

share|improve this answer
    
Looks like this indeed is a problam with multicast (IGMP) snooping in Linux (troglobit.com/blog/2013/07/09/multicast-howto). I wasn't able to fix it with this recipe shlrm.org/blog/2013/04/18/multicast-snooping-is-bad , because I don't have a bridge dir in my /sys/devices/virtual/net/vboxnet0/ on Linux 3.11.0-15. Stuck again, but at least now I know what it is. –  Victor Sergienko Jan 6 at 16:24

I could NOT get to work these two guys:

  • avahi-daemon - The Avahi mDNS/DNS-SD daemon
  • iptables — administration tool for IPv4 packet filtering and NAT

I even followed following: Well known TCP and UDP ports used by Apple software products. MAYBE you'll have better luck then me)

share|improve this answer
    
It used t work for me, without iptables though. Just stopped at some point. Reproduced twice in a totally different environments, only Virtualbox image was the same. –  Victor Sergienko Jan 4 at 9:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.