Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have SCP and SFTP transfers failing from my linux VPS server (CentOS6.5) to my local desktop Mac. The transfer starts buy fails within the first minute with the error message - "Corrupted MAC on input.Disconnecting: Packet corrupt lost connection"

I've read the other threads on this forum but neither seems to be applicable.

"Corrupted MAC on input. Packet Corrupt" on file transfer over SSH, SCP, and FTP on Linux Server

SSH sessions terminate abruptly with message: Corrupted MAC on input. Disconnecting: Packet corrupt

I've tried this from 3 different machines at the same location. All 3 give the same error, so I'm pretty sure this is not a NIC issue with the local computers.

I've had the VPS provider check the server and there doesn't seem to be any hardware issue on that end. In fact they can run the scp download from there.

cPanel tech support says, "The 'MAC' in this error message actually means 'Message Authentication Code' rather than 'Media Access Control' and a corrupted MAC in SSH means that, as the error message also states, a data packet has either been corrupted in transit possibly done intentionally by an attacker, although much more likely caused by bad hardware (or a bad NIC driver) somewhere in between you and the server. If the hardware and other network equipment check out on both ends, then the SSH packets could also be corrupted in transit by a network provider."

I've been successfully doing this same SCP transfer weekly over a year. It's the transfer of the weekly cPanel server backup.

The only thing that has changed has been that I switched from DSL to cable internet. Of course with nothing else to go on the internet provider is passing the buck at this point.

I'm wondering if besides something the provider is doing, if there is anything in the modem that could be the cause, or could be setup differently. It's a Cisco DPC3825 DOCSIS 3.0 Gateway.

Thanks for any other clues you might have to offer.

share|improve this question
    
Do you have any other devices in the network path? –  Michael Hampton Dec 27 '13 at 7:04
    
Something is mangling the data inside the TCP packets and correcting the TCP checksums to match it. (Or it's a broken NIC with TCP checksum offload.) –  David Schwartz Dec 27 '13 at 15:40
    
David, where could the "something" be located? And i'm pretty sure i've eliminated any broken NIC at my endpoint, where else could this be located? –  jim Dec 27 '13 at 15:49
    
@MichaelHampton there are no other devices, I'm directly connected to the modem. The modem has 4 ethernet ports + wireless. –  jim Dec 27 '13 at 15:50
    
Try a different cable modem, then, if you can get your hands on one. –  Michael Hampton Dec 27 '13 at 18:08

1 Answer 1

up vote 2 down vote accepted

All you can test is the devices you have control over.

You've tried 3 different local computers but there are other variables

  • Remove any devices between your ISPs cable device and your endpoints.
  • Try a known good ethernet cable to connect to your ISPs cable device.
  • Try a different port on the device.
  • Try a different device.

Try copying the file from your remote source to a different remote and see what happens. If it's clean then you know your source is good. If it fails then the source may be bad or it may be some device in the path, but you can be reasonably confident that the devices in your office are good.

Beyond that it's outside your control but at least you'll have data to present to your ISP / hosting company.

share|improve this answer
    
thanks, there are no other devices between the modem and computers. Checked shortest cable and tried all 4 ports with that cable. Don't have another modem to try. I guess I will have to try to convince the ISP to look into their equipment, my initial conversations with tech support have not been fruitful. –  jim Dec 27 '13 at 18:26
    
@jim: If you can borrow a cable modem and try that. –  Iain Dec 27 '13 at 18:29
    
I eventually got a modem from my ISP that worked. It took 3 different models before that happened. Thanks for the suggestions. –  jim Jan 12 at 17:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.