Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Im at the start of learning puppet. So far I successfully setup my master with dashboard and a couple of agents. But on one of my testing nodes I made a mistake when adding the node. I added it twice with 2 different certificates.

the first certificate is just the hostname and the other one is the FQDN. I cant seem to remove either of them properly. I used the puppet syntax for revoking the certificate. But when the next puppet run comes it adds itself to the dashboard again and gives me all kinda of errors cos its not allowed to do stuff. Im not sure if this is due to a lingering config on the master or a configuration on the agent.

how can I get a clean slate for an agent node?

share|improve this question
    
the certificate that I revoked is not in the puppet cert list --all command anymore. but still its making a catalog for it. Compiled catalog for servername.local in environment production in 0.11 seconds –  Koen van der Rijt Dec 30 '13 at 11:11
1  
You need to clean certificates from the client side as well. I'm not sure how it goes with when using dashboard and all that fancy stuff, but this how it should work with plain puppet open source: try stopping puppet agent on the client, then renaming directory /var/lib/puppet/ssl, clean certificates from the master with puppet cert clean and then run the agent with --waitforcert to create a new certificate request to the master. –  Sami Laine Dec 30 '13 at 11:11
    
it seems to have done the trick! thanks! –  Koen van der Rijt Dec 30 '13 at 11:24
    
its back :( the node just popped up again in the dashboard –  Koen van der Rijt Dec 30 '13 at 13:13
    
I think the issue is coming from the DNS server and the hostname. I made some effort to streamline that.. and redid the creation of the certificates. It seems to be oke now. I saw in the log of the dashboard it was receiving reports from and for the full FQDN and just the hostname. Maybe it has something to do with reverse lookups etc –  Koen van der Rijt Dec 30 '13 at 13:47

1 Answer 1

As you spoke about a Puppet dashboard, I will make the assertion that you are on Puppet-Enterprise.

In order to disable the agent of a node to run, you can do the following:

To do on the client:

cd /etc/init.d
service pe-mcollective stop
service pe-puppet stop
rm pe-mcollective
rm pe-puppet
rm /etc/puppetlabs/mcollective/ssl/clients/peadmin-public.pem
rm /etc/puppetlabs/mcollective/ssl/clients/puppet-dashboard-public.pem

Then, on the puppet-master, via the dashboard, you can remove this specific node in the node view.

You can find more official information there: https://docs.puppetlabs.com/pe/latest/node_deactivation.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.