Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to sync my (new) Ubuntu webserver directory to my Synology NAS.

Network backup is enabled, when I do a dry run:

rsync --dry-run . rsync://root@192.168.1.150

It shows the available modules.

When I try to sync with rsync it fails with the message:

@ERROR: host is denied to login

Syncing is done with this script:

#!/bin/bash
RSYNC="/usr/bin/rsync -a --delete"
export RSYNC_PASSWORD=MyPasswrd
rsync -avz -t --timeout=1200 /var/www/ root@192.168.1.150::NetBackup/web/var/www/

All directories are tested. This worked on my previous Ubuntu server (10.04)

/var/log/rsyncd.log:

2013/12/31 02:22:58 [8601] rsyncd version 3.0.9 starting, listening on port 873
2013/12/31 02:23:05 [10188] name lookup failed for 192.168.1.51: Name or service not known
2013/12/31 02:23:05 [10188] connect from UNKNOWN (192.168.1.51)
2013/12/31 02:23:05 [10188] module-list request from UNKNOWN (192.168.1.51)
2013/12/31 02:23:19 [11408] name lookup failed for 192.168.1.51: Name or service not known
2013/12/31 02:23:19 [11408] connect from UNKNOWN (192.168.1.51)
2013/12/31 02:23:19 [11408] rsync error: IP is denied by remote machine (code 50) at authenticate.c(563) [Receiver=3.0.9]

UPDATE

My database server, same Ubuntu version, installed as a second server together with my webserver is using the same script:

#backup the tables to NAS
RSYNC="/usr/bin/rsync -a --delete"
export RSYNC_PASSWORD=MyPasswrd
rsync -avz -t  --timeout=1200 /home/user/backup/mysql/ root@192.168.1.150::NetBackup/mysqldb/

And this works flawlessly...

UPDATE 2*

with verbose (-v)

opening tcp connection to 192.168.1.150 port 873
sending daemon args: --server -vvlogDtprze.iLsf --timeout=1200 . NetBackup/webserver/var/www/
@ERROR: host is denied to login
rsync error: error starting client-server protocol (code 5) at main.c(1534) [sender=3.0.9]
share|improve this question
    
Sounds like the NAS is not allowing the new Ubuntu webserver to login. Are there any rsync permissions on the NAS that need to be updated ? –  Lawrence Dec 31 '13 at 2:04
    
No. I have also a new Ubuntu database server, made them together which is succesfully syncing the mysql dumps with exactly the same rsync script... –  Klaaz Dec 31 '13 at 9:08
    
Can you run rsync with the -v option to get more verbose output? –  Gabriel Talavera Dec 31 '13 at 9:31
    
Offcourse. See update! –  Klaaz Dec 31 '13 at 9:56

2 Answers 2

up vote 1 down vote accepted

Sounds like that IP has been banned for some reason, (too many bad password attempts?).

You could try changing the ip to verify, if that's easy to do in your case.

This link may prove helpful: http://forum.synology.com/enu/viewtopic.php?f=145&t=22084

share|improve this answer
    
Allthough this was not really the case it put me on track. I restrict access to my Syno based on failed access by users. And it seemed that the IP was banned by this functionality. I never expected this to happen because I never logged in to my Syno from this box. –  Klaaz Jan 2 at 12:12

Although not supported, you can try to either remove the IP address of the new server from /etc/hosts.deny in the Synology NAS (if is there for some reason, like a fail2ban rule) or add it to /etc/hosts.allow

share|improve this answer
    
Good suggestion but did not work in my case. Thanks anyway! –  Klaaz Jan 2 at 12:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.